Sisyphus changes — различия между версиями

Материал из ALT Linux Wiki
Перейти к: навигация, поиск
м (Февраль: xfce4)
м (Февраль: уточнение по k-m-nvidia-un-def)
Строка 17: Строка 17:
 
Пользователям {{pkg|xfce4-session}} и {{pkg|xfce4-power-manager}} без {{pkg|systemd}} стоит обратить внимание на [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363465.html анонс майнтейнера] и, возможно, подстроить {{pkg|polkit}}.
 
Пользователям {{pkg|xfce4-session}} и {{pkg|xfce4-power-manager}} без {{pkg|systemd}} стоит обратить внимание на [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363465.html анонс майнтейнера] и, возможно, подстроить {{pkg|polkit}}.
  
Для {{pkg|kernel-image-un-def}} пока [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363452.html не собирается] модуль nvidia, пользователям соответствующих видеокарт рекомендуется обождать или на 3.18.7, или на std-def.
+
Для {{pkg|kernel-image-un-def}} пока [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363452.html не собирается] модуль nvidia, пользователям соответствующих видеокарт рекомендуется обождать или на 3.18.7, или на std-def. ''346.47 для 3.19.3 собрано''
  
 
Если после обновления {{pkg|nfs-utils}} до 1.3.2 при попытке монтирования NFS получается <tt>mount.nfs: an incorrect mount option was specified</tt> — обратите внимание на [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363371.html рекомендации майнтейнера]. '''NB:''' в случае использования {{pkg|systemd}} в нагрузку можно получить ещё и [https://bugzilla.altlinux.org/show_bug.cgi?id=30708 #30708].
 
Если после обновления {{pkg|nfs-utils}} до 1.3.2 при попытке монтирования NFS получается <tt>mount.nfs: an incorrect mount option was specified</tt> — обратите внимание на [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363371.html рекомендации майнтейнера]. '''NB:''' в случае использования {{pkg|systemd}} в нагрузку можно получить ещё и [https://bugzilla.altlinux.org/show_bug.cgi?id=30708 #30708].

Версия 08:58, 11 апреля 2015

50px-Gnome globe current event.png
Данная статья периодически обновляется.
Последнее обновление
08:58 11 апреля 2015

Замечания об обновлении Sisyphus

Zn1 26.gif Здесь собираются важные замечания, связанные с обновлением системы из Sisyphus; текущие критичные ошибки отмечены на altbug #9100. Пожалуйста, если вы вносите предупреждения заранее, то потом либо убирайте их, либо конкретизируйте проблему. Извещения «месяц назад надо было бояться» бесполезны.

Старые по меркам Сизифа замечания накапливаются в архиве.

Рекомендации

2015

Февраль

Пользователям xfce4-session и xfce4-power-manager без systemd стоит обратить внимание на анонс майнтейнера и, возможно, подстроить polkit.

Для kernel-image-un-def пока не собирается модуль nvidia, пользователям соответствующих видеокарт рекомендуется обождать или на 3.18.7, или на std-def. 346.47 для 3.19.3 собрано

Если после обновления nfs-utils до 1.3.2 при попытке монтирования NFS получается mount.nfs: an incorrect mount option was specified — обратите внимание на рекомендации майнтейнера. NB: в случае использования systemd в нагрузку можно получить ещё и #30708.

Январь

Если openvpn после обновления до 2.3.6 перестал поднимать туннели из-под etcnet, проверьте логи на предмет '/var/lib/openvpn//tmp/.private/root': No such file or directory и добавьте в /etc/net/ifaces/*/ovpnoptions строчку tmp-dir /tmp для задействования /var/lib/openvpn/tmp (более не требуется с etcnet >= 0.9.10-alt18).

2014

Ноябрь

ImageMagick (convert и т.д.) могут процессорозависимо падать вследствие altbug #30442 (после исправления предыдущей аналогичной altbug #30431).

Сентябрь

Если apt-0.5.15lorg2-alt46.1 сделал segmentation fault — зачистите кэш: rm -f /var/cache/apt/*.bin

Август

Рекомендации ПЕРЕД обновлением akonadi до >= 1.12.90.

Июнь

Стоит воздержаться от обновления до systemd-214-alt1 (по состоянию на отправленный сегодня -alt6 всё так же возможны проблемы с NetworkManager и запуском графической сессии).

Поскольку mksquashfs из squashfs-tools-4.3-alt1 требует смонтированного /proc, без обновления mkimage до 0.2.15+ можно узреть FATAL ERROR:Mksquashfs requires more physical memory than is available!; также возможны сбои при сборке крупных i586-образов на x86_64; см. altbug #30103; исправлено в 4.3-alt2.

Апрель

Если после обновления LibreOffice4 начались зависания на старте, удалите пока LibreOffice4-kde, см. тж. altbug #30042 (исправлено в 4.2-alt1.M70P.2).

Март

Akonadi 1.12 иногда портит базу, перед обновлением до этой версии рекомендуется остановить его при помощи akonadictl stop (либо сделать резервную копию из akonaditray).

Если вдруг при обновленьи отвалился realtek, Вы проверьте, нет ли в корне /etc/modprobe.d/blacklist-r8168.conf. И если есть -- удалите пакет r8168-blacklist вместе с kernel-modules-r8168-*.

systemd-210 сломал i586-системы при помощи переполнения queue file в /run вследствие чрезмерного внимания к netlink после добавления networkd. Вариант объезда, либо обновите make-initrd до 0.8.8-alt1+ и перегенерируйте initrd.

Ссылки