Sisyphus changes

Материал из ALT Linux Wiki

Перейти к: навигация, поиск
50px-Gnome globe current event.png
Данная статья периодически обновляется.
Последнее обновление
08:55 09 февраля 2017

Содержание

[править] Замечания об обновлении Sisyphus

Zn1 26.gif Здесь собираются важные замечания, связанные с обновлением системы из Sisyphus; обновления по безопасности отмечаются на этой страничке.

Пожалуйста, если вносите предупреждения заранее, то потом либо убирайте их, либо конкретизируйте проблему. Извещения «месяц назад надо было бояться» бесполезны.

Старые по меркам Сизифа замечания накапливаются в архиве.

[править] Рекомендации

[править] 2017

[править] Февраль

Просьба дождаться обновления lua5.1 до сборки 5.1.5-alt5, в -alt4 есть необъявленный конфликт, ломающий dist-upgrade.

[править] Январь

systemd-232-alt1 не работает на i586 -- избегайте обновления 32-битных систем до этой версии; исправление доступно в сборке 232-alt2.git.486b3d0 (ожидается на ftp 4.02.2017, сборочное задание 177580).

dhcp-server-4.3.3-alt4 не отвечает не запросы, помогает откат на -alt3. Обсуждается в 33053. Сломанную сборку успели портировать в p8.

При обновлении хостов под управлением systemd до 232-alt1 использующим контейнерную виртуализацию следует обратить внимание на это письмо.

Ошибка 32997 с новым rpm при обновлении glibc-locales, если задано ограничение языков через %_install_langs в /etc/rpm/macros. Временно можно поменять %_install_langs на all и переустановить glibc-locales.

[править] 2016

[править] Декабрь

"Пока не обновляйтесь на новый Сизиф: apt сломался из-за линковки со старым liblua, в то время как librpm слинковался с новым." (#32931) --> рецепт исправления с apt-0.5.15lorg2-alt56 --> исправлено в Sisyphus-20161222

RPM обновлён до 4.13 (rpm-build это пока не касается); обновление rpm и apt рекомендуется делать с помощью apt-get dist-upgrade[1], при этом apt-shell, synaptic, aptitude могут упасть с руганью.

[править] Октябрь

MATE оказался частично обновлён до 1.16 (07.10.2016), просьба дождаться завершения обновления (11.10.2016: похоже, уже в достаточной мере добралось).

[править] Июнь

В Сизиф попал недостаточно протестированный alterator-fbi 5.32-alt1.1, это будет исправлено сегодня, но из сегодняшнего Сизифа его обновлять не рекомендуется. (23.06.2016)

[править] Февраль

Если при попытке монтирования NFS получаете mount.nfs: Protocol not supported -- добавьте в опции монтирования v3, умолчание сменилось на NFSv4.

Если молча перестали писаться логи посредством rsyslog-а (после его обновления) - возможно нужно доустановить rsyslog-classic. См. тикет.

[править] Январь

ВАЖНО: в openssh-clients-7.1p1-alt1 по умолчанию выключена поддержка ключей типа ssh-dss (DSA); рекомендуется отказаться от их использования в пользу[2] ED25519, больших RSA (от 2048 бит) либо ECDSA, а при необходимости[3] добавить в соответствующие Host-записи ~/.ssh/config разрешение на их использование:

PubkeyAcceptedKeyTypes +ssh-dss,ssh-dss-cert-v01@openssh.com

Могут возникнуть проблемы при работе с устаревшими реализациями SSH в оборудовании вроде Cisco, при этом следует изучить лог подключения ssh -v и дописать для нужного хоста или группы хостов разрешение:

KexAlgorithms +diffie-hellman-group1-sha1

Также в этой сборке учтена уязвимость UseRoaming.

[править] 2015

[править] Декабрь

В ntp-4.2.8-alt3 из-за коллизии при установке пропадает /var/lib/ntpd/etc/services, рекомендуется apt-get reinstall ntpd либо update_chrooted conf && service ntpd restart; исправлено в 4.2.8-alt4.

[править] Октябрь

OTRS 5.0.1 может потребовать вмешательства при обновлении с 4.0.13.

В nvidia_glx_common-352.55-alt155 добавлен скрипт nvidia-clean-driver, удаляющий ненужные пакеты nvidia_glx_*.

[править] Сентябрь

При обновлении mariadb с 5.5.34 до 10.0.21 следует обратить внимание на то, что сборка переведена в чрут аналогично MySQL-server; может понадобиться удаление /etc/my.cnf.d/server.cnf, т.к. рабочим конфигом является /var/lib/mysql/my.cnf (см. тж. вывод /usr/bin/my_print_defaults mysqld).

[править] Февраль

Пользователям xfce4-session и xfce4-power-manager без systemd стоит обратить внимание на анонс майнтейнера и, возможно, подстроить polkit.

Для kernel-image-un-def пока не собирается модуль nvidia, пользователям соответствующих видеокарт рекомендуется обождать или на 3.18.7, или на std-def. 346.47 для 3.19.3 собрано

Если после обновления nfs-utils до 1.3.2 при попытке монтирования NFS получается mount.nfs: an incorrect mount option was specified — обратите внимание на рекомендации майнтейнера. NB: в случае использования systemd в нагрузку можно получить ещё и #30708.

[править] Январь

Если openvpn после обновления до 2.3.6 перестал поднимать туннели из-под etcnet, проверьте логи на предмет '/var/lib/openvpn//tmp/.private/root': No such file or directory и добавьте в /etc/net/ifaces/*/ovpnoptions строчку tmp-dir /tmp для задействования /var/lib/openvpn/tmp (более не требуется с etcnet >= 0.9.10-alt18).

[править] Ссылки

  1. см. https://lists.altlinux.org/pipermail/sisyphus/2016-December/365691.html
  2. см. тж. рекомендации в статье "Работа с ключами разработчика"
  3. ...бишь в случае получения сообщения ssh: Permission denied (publickey). при control sshd-password-auth disabled на сервере либо неожиданном запросе пользовательского пароля, если он на сервере разрешён (по умолчанию)
 
Личные инструменты