Эльбрус/hcl/gpu

Материал из ALT Linux Wiki
Перейти к: навигация, поиск

Совместимость видеокарт[править]

Общие критерии[править]

Как правило, поддерживаются карты на тех же видеочипах, которые установлены на комплектных видеокартах:

Проверенные[править]

Наименование Версия ПНС Версия
ядра
Тип ВК Комментарии
1 AMD Radeon HD6670 МЦСТ[3]
2 AMD Radeon HD6450 3.14, 4.9 401-РС МЦСТ[3][4]; комплектная
3 AMD Radeon E6460 МЦСТ[3]
4 AMD Radeon R5 230 3.14, 4.9 801-РС МЦСТ[3]
5 AMD Radeon HD6570 МЦСТ[5]
6 AMD Radeon HD6790...HD6990 МЦСТ[5]
7 AMD Radeon HD64xxM МЦСТ[5]
8 AMD Radeon HD67xxM МЦСТ[5]
9 AMD Radeon HD69xxM МЦСТ[5]
10 AMD Radeon HD7450...HD7670 МЦСТ[5]
11 AMD Radeon HD3650 МЦСТ[6]
12 AMD Radeon HD2400 МЦСТ[6]
13 AMD Radeon R7 250 3.14, 4.9 МЦСТ[3][4]
14 AMD Radeon R7 370 3.14, 4.9 МЦСТ; медленно[4]
15 AMD Radeon R9 280X 3.14, 4.9 МЦСТ; медленно[4]
16 AMD Radeon RX 460 4.9 МЦСТ[7]
17 AMD Radeon RX 480 4.9 МЦСТ[7]
18 AMD Radeon RX 550 4.9 МЦСТ[7][8]
19 nVidia EN8600GT --- МЦСТ; пока не работает, ведутся работы
20 nVidia GeForce 8800 GTS 4.9 МЦСТ[9]
21 USB-видеокарта (UDL) HIS Multi-View II 3.14, 4.9 МЦСТ[10]
22 USB-видеомонитор (UDL) Philips 221S3U 3.14, 4.9 МЦСТ[11]
23 nVidia GTX1050 4.19 E8C-SWTX МЦСТ[12]
  • Radeon RX 580 801-РС; ядро 4.9-4.3 и выше, соотв. firmware

Предположительно[править]

  • Radeon RX470 по сути тот же чип, что и в RX580

Экспериментально[править]

В экспериментальном порядке можно попытаться задействовать карты NVIDIA, доустановив или скомпилировав видеодрайвер (модуль ядра nouveau.ko входит в недавние выпуски ядра 4.9 в составе OSL/ALT), но как минимум в ПНС их поддержки пока ждать не приходится.

Примечания[править]

  1. в основном семейств R600/R300, в новых выпусках ОС Эльбрус и ОС Альт могут работать AMDGPU отдельных R-серий
  2. в ОС Альт поддержка SiliconMotion доступна без аппаратного ускорения
  3. 3,0 3,1 3,2 3,3 3,4 Поддержка в буте/ядре
  4. 4,0 4,1 4,2 4,3 Сводка по быстродействию (PDF)
  5. 5,0 5,1 5,2 5,3 5,4 5,5 Вероятно, не будет особых проблем, однако потребуется выпустить обновление ядра linux с включением firmware для этих карт
  6. 6,0 6,1 Использовать не рекомендуется (устаревшие, не поддерживают новые версии OpenGL)
  7. 7,0 7,1 7,2 3.14: поддержка невозможна; 4.9: работает нестабильно, требуется исправление проблем
  8. Требуется бэкпортирование драйвера из ядра >=4.10, а лучше - переход на ядро >=4.10 (см. #97250).
  9. Работает (без OpenCL; см. bug 107290).
  10. Работает (после поправки bug 99084). О настройке см. ниже.
  11. 3.14: пока не работает, ведутся работы (см. bug 99958); 4.9: работает. О настройке см. ниже.
  12. Работает (OpenGL до 4.3). Поддержка в Linux есть с 4.12, так что на 4.9 и 3.14 работать не будет. Кроме того, не работают OpenCL и Vulkan (впрочем, и не должны).