Update/p7 — различия между версиями

Материал из ALT Linux Wiki
Перейти к: навигация, поиск
(4. Обновиться до p7:)
Строка 176: Строка 176:
 
[[Категория:HOWTO]]
 
[[Категория:HOWTO]]
 
[[Категория:APT]]
 
[[Категория:APT]]
[[Категория:Admin]]
 
 
[[Категория:Branches]]
 
[[Категория:Branches]]
 
[[Категория:Changes]]
 
[[Категория:Changes]]
 
[[Категория:Upgrade]]
 
[[Категория:Upgrade]]
 +
{{Category navigation|title=Обновление|category=Upgrade|sortkey={{SUBPAGENAME}}}}
 
[[Категория:FAQ]]
 
[[Категория:FAQ]]

Версия 15:05, 1 июля 2015

Процедура обновления с p6 до p7 аналогична обновлению до p6:

Примечание: Инструкция по обновлению с p5 на p6 расположена на другой странице


Содержание

Обновление

0. Желательно перед обновлением системы удалить все ненужные вам пакеты, и отключить ненужные сервисные службы. Это сэкономит вам некоторое время в процессе обновления, и уменьшит трафик скачанных пакетов.

1. Обновить дистрибутив до самого свежего p6:

apt-get update
apt-get dist-upgrade
update-kernel (После обновления ядра - перезагружаемся).

Если используете репозитории Arepo,(в 64-битной системе), нужно явно переустановить все пакеты i586 и обновить libstdc++6:

apt-get reinstall $(rpmquery -a --qf '%{name}.32bit ' 'i586-*')
apt-get install libstdc++6 i586-libstdc++6

2. Если не установлена, установить обновлённую программу apt-repo

apt-get install apt-repo

3. Изменить источники обновления:

apt-repo rm all
apt-repo add branch p7

4. Обновиться до p7:

Внимание! Так как обновление затрагивает и службу D-Bus, процесс обновления может вызвать падение Xorg. Поэтому указанные команды лучше вводить под правами root в консоли (Нажмите Ctrl+Alt+F2, введите root и пароль пользователя root):
apt-get update
apt-get dist-upgrade

Если на этом этапе (как и на аналогичном этапе при обновлении до p6), выявляются ошибки в зависимостях, заносим их в багзилу. Часто срабатывает приём - удаление проблемного пакета с помощью

rpm -e имя_пакета

С последующим его восстановлением

apt-get -f install

и повторением после этого

apt-get dist-upgrade

Если не установлен libicu50

apt-get install libicu50
apt-get dist-upgrade

Дальше:

 update-kernel
 apt-get install firmware-linux

Последняя команда нужна, т.к. раньше firmware распространялись вместе с ядром, а теперь вынесены в отдельный пакет. Команда необходима для устройств, использующих firmware, например, для сетевых контролёров bnx2.

depmod -a

Обратите внимание: команда depmod -a является страховочной, т.к. соответствующие изменения в bootloader-utils могли не оказаться на системе на базе бранча t6/p6. Характерным признаком возможной проблемы является диагностика вроде «modprobe: ERROR: magic check fail».

5. На рабочих станциях желательно установить Systemd

(без него у вас не будет автомонтирования внешних устройств и не будет работать NetworkManager от обычного подьзователя - см.Sysvinit, Regular/icewm)

Прочтите внимательно про Systemd.

apt-get install systemd-sysvinit
Перезагрузите компьютер.

6. Перезагрузитесь

Примечание: При смене SysVInit на Systemd машина при перезагрузке показывает приглашение к восстановлению (maintenance). Нажмите Enter и укажите пароль пользователя root. Затем наберите команду
reboot 
и нажмите Enter. Система будет перезагружена.


7. Включите автозапуск NetworkManager:

 systemctl enable NetworkManager

или по-старому

 chkconfig NetworkManager on

Если у вас компьютер работает в домене, или монтирует внешние устройства по сети, включите NetworkManager-wait-online:

 systemctl enable NetworkManager-wait-online
 (chkconfig NetworkManager on)

а для работы с модемами:

 systemctl enable ModemManager
 (chkconfig ModemManager on)

а затем сразу-же и включите их с помощью команды service, например:

 service NetworkManager start
Примечание: Если systemctl отвечает ошибкой, добавляйте к каждой команде определение .service :
 systemctl enable NetworkManager.service
 systemctl enable NetworkManager-wait-online.service
 systemctl enable ModemManager.service


8. С помощью команды

systemctl list-unit-files  | grep disable

смотрим какие ещё нужные службы были отключены в процессе перехода на systemd, и при необходимости, включаем их

chkconfig имя_службы on

или по-новому:

systemctl enable имя_службы.service

Для включения их в текущем сеансе, используем:

service имя_службы start

9. Для любителей графического интерфейса, можно (если не установлен), установить alterator-service, и настраивать запуск служб из него.

Размер обновлений

Название дистрибутива Размер скачиваемого обновления, МБ
Альт Линукс 6.0 Кентавр 1 682
Simply Linux 6.0 2 013
Альт Линукс 6.0 KDesktop 2 719

Возможные проблемы

1. Проприетарный драйвер ATI/AMD (fglrx) не совместим с xorg-server 1.14

Графическая подсистема, использующая этот драйвер, после обновления не будет работать.

Варианты решения:

  1. (рекомендуется) до обновления системы заменить драйвер на свободный (radeon), например при помощи alterator-x11
  2. отказаться от обновления системы в целом до выпуска фирмой AMD драйвера fglrx, совместимого с новым сервером xorg
  3. не обновлять графическую подсистему до выпуска нового драйвера fglrx (требует квалификации)

Заметим, что драйвер fglrx не устанавливается по умолчанию в дистрибутивах ALT Linux.

2. С сетевыми интерфейсами может случиться неразбериха

Интерфейсы ethX изменились на enpXsY [1]

Исправление:

apt-get install udev-rule-generator-net
Внимание! Пока не работает: altbug #29280 altbug #29282


3. На виртуальных машинах VirtualBox с чипсетом PIIX3 может не запуститься

Исправление:

Сменить в свойствах виртуальной машины Система  ⇒ Чипсет: ICH9 (также нужно включить IO APIC в той же вкладке)

4. При обновлении может быть удалён пакет i586-wine-vanilla или i586-wine

Исправление:

apt-get install i586-wine-vanilla i586-libwine-vanilla-gl i586-libwine-vanilla-twain
или
apt-get install i586-wine i586-libwine-gl i586-libwine-twain

5. При обновлении Simply Linux устанавливаются обои XFCE по умолчанию (с мышкой)

Вернуть фирменные обои:

Выберите в контекстном меню рабочего стола «Настройка рабочего стола...» и выберите подходящие обои (фирменные обои по умолчанию называются slinux*).

6. При обновлении Simply Linux панель задач не расширяется до области уведомлений

Данное поведение вызвано изменениями в XFCE:

Нужно вручную поставить «Разделитель» между панелью задач и областью уведомлений (треем) и поставить галочку расширения.

7. Если не показываются значки в приложениях GNOME

Установите пакет gnome-icon-theme-symbolic

apt-get install gnome-icon-theme-symbolic

8. Если используются приложения GTK3

Для единообразного вида приложений GTK2 и GTK3 установите тему gtk3-theme-clearlooks-phenix:

apt-get install gtk3-theme-clearlooks-phenix

9. Обновление TDE (KDE3)

После обновления удалите в домашнем каталоге пользователя файл

rm ~/.mcoprc

Точечные обновления пакетов из p7 на p6 (опасно!)

См. Точечные обновления пакетов из p7 на p6.


Демонстационный материал

<swf>http://www.youtube.com/watch?v=n6lIH8D-Abw%7Cwidth=300%7Cheight=200</swf>

Обновление Simply Linux 6.0.1 (бранч p6) до бранча p7