Обсуждение:Backports Policy

Материал из ALT Linux Wiki
Перейти к: навигация, поиск

Пояснение того, как правильно делать бекпорты:

http://lists.altlinux.org/pipermail/devel-newbies/2009-October/000059.html

Предположим, некоторый пакет в сизиф собран с версией-релизом 1.0-alt1
Этот же пакет, при необходимости, в соответствии с  http://www.altlinux.org/BackportsPolicy должен быть
собран в предыдущие бранчи с меньшим номером версии-релиза.
В бранче 5.0 это будет 1.0-alt0.M50.1
В бранче 4.1 это будет 1.0-alt0.M41.1
В бранче 4.0 это будет 1.0-alt0.M40.1

Предположим, нам надо что-то исправить в версии для бранча 4.0.
Например, мы забыли о том, что в 4.0 еще не было триггеров (http://www.altlinux.org/RPMFileTrigger)
и положенные в пакет альтернативы/файлы *.desktop нужно обновить в работающей системе вручную.

Дописываем соответствующие строки в спек, и собираем пакет как 1.0-alt0.M40.2 
Т.к. 1.0-alt0.M40.2 < 1.0-alt0.M41.1 < 1.0-alt0.M50.1 < 1.0-alt1 ошибки такое обновление не вызовет,
а т.к. изменение касается одного только бранча, мы имеем право изменять минорный релиз.

Собирать же во все старшие репозитории пакет с таким изменением будет ошибкой.

——ТимурБатыршин