Zoom — различия между версиями

Материал из ALT Linux Wiki
Перейти к: навигация, поиск
 
(не показана 1 промежуточная версия 1 участника)
Строка 1: Строка 1:
 
Zoom (https://zoom.us/) — это сервис для проведения видеоконференций, онлайн-встреч и создания групповых чатов. Имеет смысл следить за уведомлениями о проблемах с безопасностью<ref>[https://roskomsvoboda.org/57005/ Zoom извинилась за «дыры» в безопасности и занялась исправлением багов]</ref>.
 
Zoom (https://zoom.us/) — это сервис для проведения видеоконференций, онлайн-встреч и создания групповых чатов. Имеет смысл следить за уведомлениями о проблемах с безопасностью<ref>[https://roskomsvoboda.org/57005/ Zoom извинилась за «дыры» в безопасности и занялась исправлением багов]</ref>.
  
=Установка клиента (все команды выполняются под правами root)=
+
=Установка клиента из пакета (все команды выполняются под правами root)=
 
<div style='padding:6px;border:1px solid red;'>Речь только про 64-разрядный пакет. 32-разрядный zoom_i686.rpm для CenOS в ALT Linux не установится по зависимости на архитектуру x86-32 &mdash; [https://forum.altlinux.org/index.php?topic=43896.msg349311#msg349311 mesa-dri-drivers (x86-32)].</div>
 
<div style='padding:6px;border:1px solid red;'>Речь только про 64-разрядный пакет. 32-разрядный zoom_i686.rpm для CenOS в ALT Linux не установится по зависимости на архитектуру x86-32 &mdash; [https://forum.altlinux.org/index.php?topic=43896.msg349311#msg349311 mesa-dri-drivers (x86-32)].</div>
 
<hr align="left" width="0" size="1" color="#000000"/>
 
<hr align="left" width="0" size="1" color="#000000"/>
Строка 11: Строка 11:
 
* в выпадающем списке «Версия» &mdash; свежую, (для c8.1 нужно скачивать версию для CentOS 6.4, ибо версия для 7.0 хочет зависимость freetype >= 2.6, а в ALT пакет называется libfreetype)
 
* в выпадающем списке «Версия» &mdash; свежую, (для c8.1 нужно скачивать версию для CentOS 6.4, ибо версия для 7.0 хочет зависимость freetype >= 2.6, а в ALT пакет называется libfreetype)
 
* нажать кнопку «Загрузить».
 
* нажать кнопку «Загрузить».
[[Изображение:Zoom-download.png|Загрузка Zoom.rpm]]
+
[[Изображение:Zoom-download.png|Загрузка Zoom.rpm|center]]
  
 
==Установка==
 
==Установка==
Строка 20: Строка 20:
 
А уж после установить результат пересборки, например:
 
А уж после установить результат пересборки, например:
 
<source lang="text" highlight="1"># apt-get install /home/user/Загрузки/zoom-5.2.454870.0831-alt1.repacked.with.epm.2.x86_64.rpm</source>
 
<source lang="text" highlight="1"># apt-get install /home/user/Загрузки/zoom-5.2.454870.0831-alt1.repacked.with.epm.2.x86_64.rpm</source>
 +
 +
{{Note|При наличии пакета {{pkg|eepm}}, начиная с версии 3.5.0-alt1, можно установить Zoom одной командой:
 +
<source lang="text" highlight="1"># epm play zoom</source>
 +
Пакет при этом будет скачан с официального сайта.
 +
}}
 +
 
==Запуск==
 
==Запуск==
 
Можно запускать («Меню запуска приложений» → «Интернет/Сеть» → «Zoom» или командой <code>$ zoom</code>):
 
Можно запускать («Меню запуска приложений» → «Интернет/Сеть» → «Zoom» или командой <code>$ zoom</code>):
  
[[Изображение:Zoom.png|Клиент Zoom]]
+
[[Изображение:Zoom.png|Клиент Zoom|center]]
  
 
Выбрать язык из контекстного меню значка Zoom в области уведомлений:
 
Выбрать язык из контекстного меню значка Zoom в области уведомлений:
  
[[Изображение:Zoom-lang.png|Переключить язык в Zoom]]
+
[[Изображение:Zoom-lang.png|Переключить язык в Zoom|center]]
 +
 
 +
=Установка клиента из Flatpack=
 +
 
 +
# apt-get install flatpak
 +
 
 +
# flatpak remote-add flathub https://flathub.org/repo/flathub.flatpakrepo
 +
 
 +
# flatpak install flathub us.zoom.Zoom
 +
 
 +
Запуск:
 +
$ flatpak run us.zoom.Zoom
 +
 
 +
После перевхода в систему элементы программ будет в меню.
 +
 
 +
Чтобы обновить программу до новой версии введите команду:
 +
# flatpak update
  
 
=Работа через прокси-сервер=
 
=Работа через прокси-сервер=

Текущая версия на 07:55, 2 марта 2021

Zoom (https://zoom.us/) — это сервис для проведения видеоконференций, онлайн-встреч и создания групповых чатов. Имеет смысл следить за уведомлениями о проблемах с безопасностью[1].

Установка клиента из пакета (все команды выполняются под правами root)[править]

Речь только про 64-разрядный пакет. 32-разрядный zoom_i686.rpm для CenOS в ALT Linux не установится по зависимости на архитектуру x86-32 — mesa-dri-drivers (x86-32).

Название пакета у Zoom Conferencing совпадает с пакетом приложения Z-Machine, и если последний используется, установка Zoom Conferencing его заместит.

Загрузка[править]

Получить 64-разрядный пакет отсюда:

  • в выпадающем списке «Тип Linux» выбрать «CentOS»,
  • в выпадающем списке «Архитектура ОС» — нужную,
  • в выпадающем списке «Версия» — свежую, (для c8.1 нужно скачивать версию для CentOS 6.4, ибо версия для 7.0 хочет зависимость freetype >= 2.6, а в ALT пакет называется libfreetype)
  • нажать кнопку «Загрузить».
Загрузка Zoom.rpm

Установка[править]

Применительно к скачанному пакету выполнить команду apt-get install /маршрут/к/файлу/zoom_<архитектура>.rpm, например:

# apt-get install /home/user/Загрузки/zoom_x86_64.rpm

Но предварительно лучше всё же его пересобрать под текущего Альта (от обычного пользователя):

$ epm repack /home/user/Загрузки/zoom_x86_64.rpm

А уж после установить результат пересборки, например:

# apt-get install /home/user/Загрузки/zoom-5.2.454870.0831-alt1.repacked.with.epm.2.x86_64.rpm
Примечание: При наличии пакета eepm, начиная с версии 3.5.0-alt1, можно установить Zoom одной командой:
# epm play zoom

Пакет при этом будет скачан с официального сайта.


Запуск[править]

Можно запускать («Меню запуска приложений» → «Интернет/Сеть» → «Zoom» или командой $ zoom):

Клиент Zoom

Выбрать язык из контекстного меню значка Zoom в области уведомлений:

Переключить язык в Zoom

Установка клиента из Flatpack[править]

# apt-get install flatpak
# flatpak remote-add flathub https://flathub.org/repo/flathub.flatpakrepo
# flatpak install flathub us.zoom.Zoom

Запуск:

$ flatpak run us.zoom.Zoom

После перевхода в систему элементы программ будет в меню.

Чтобы обновить программу до новой версии введите команду:

# flatpak update

Работа через прокси-сервер[править]

Многие проприетарные продукты понимают глобальные настройки прокси в Windows, при этом игнорируя их в линуксе. Но и на эти хитрые проги найдётся толкатель с левой резьбой, а именно — proxychains:

# apt-get install -y proxychains

Настроить прокси в /etc/proxychains.conf и запускать:

$ proxychains <program>

А в данном случае проще поправить прямо файл меню, заменив в /usr/share/applications/Zoom.desktop строку

Exec=/usr/bin/zoom %U

на

Exec=proxychains zoom %U

Примечания[править]