Viber

Материал из ALT Linux Wiki
Перейти к: навигация, поиск

Установка Viber под ALT Linux.

Внимание! На сайте Viber доступна только версия под 64-битные системы. Если у вас 32-битная система, то Viber не установится.
Внимание! При первом запуске Viber потребует наличие приложения Viber на Вашем телефоне.


Ставимся непосредственно с официального сайта (всё от root)

Удостоверяемся в наличии необходимого инструментария

# apt-get install -y ca-trust elinks sed wget

Сливаем и устанавливаем свежий релиз

# wget https://download.cdn.viber.com/desktop/Linux/viber.rpm &&
  rpm -Uhv viber.rpm

Добавляем и обновляем сертификаты

Сохраняем в /usr/share/pki/ca-trust-source/anchors/ корневые сертификаты Thawte:

# for SRC in www.thawte.com/roots/thawte_Premium_Server_CA.pem github.com/katmagic/https-everywhere/blob/master/cert-validity/mozilla/builtin-certs/Thawte_Premium_Server_CA.crt; do
      TGT=/usr/share/pki/ca-trust-source/anchors/`basename $SRC`
      [ -f $TGT ] || elinks -dump https://$SRC | sed -n '/----/,/----/p;s/\r//' >$TGT
  done &&
  update-ca-trust

NB: вышеприведённые манипуляции с сертификатами способствуют в т.ч. работоспособности DropBox.

UPD для 9 платформы (KDEsktop) и 10 версии вайбера

В данном случае собранному для Федоры вайберу, казалось бы, требуется лишь gstreamer1 с плагинами:

# rpm -Uhv viber.rpm
Upgrading "viber.rpm"
ошибка: Неудовлетворенные зависимости:
        gstreamer1(x86-64) нужен для viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-bad-free(x86-64) нужен для viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-base(x86-64) нужен для viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-good(x86-64) нужен для viber-10.3.0.37-2.x86_64
        gstreamer1-plugins-ugly-free(x86-64) нужен для viber-10.3.0.37-2.x86_64

Однако всё это, вероятней всего, уже установлено:

# apt-get install gstreamer1.0 gst-plugins-base1.0 gst-plugins-bad1.0 gst-plugins-ugly1.0 gst-plugins-good1.0 gst-plugins-good1.0-qt5
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия gstreamer1.0 уже установлена.
Последняя версия gst-plugins-base1.0 уже установлена.
Последняя версия gst-plugins-bad1.0 уже установлена.
Последняя версия gst-plugins-ugly1.0 уже установлена.
Последняя версия gst-plugins-good1.0 уже установлена.
Следующие НОВЫЕ пакеты будут установлены:
  gst-plugins-good1.0-qt5

Если установить его в наглую (# rpm -Uhv --nodeps viber.rpm), он запускается и даже работает. Но при обновлениях системы предлагается к сносу.

Чтоб такого не происходило, понадобится пакет eepm:

# apt-get install eepm

Посредством которого можно сконвертировать федоровский rpm в альт-линуксовый:

# epm repack viber.rpm

Конвертация приведёт к созданию viber-alt1.repacked.with.epm.3.x86_64.rpm, каковой уже можно спокойно установить:

# apt-get install viber-alt1.repacked.with.epm.3.x86_64.rpm 
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано viber для 'viber-alt1.repacked.with.epm.3.x86_64.rpm'
Следующие НОВЫЕ пакеты будут установлены:
  viber
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 53 не будет обновлено.
Необходимо получить 0B/93,4MB архивов.
После распаковки потребуется дополнительно 321MB дискового пространства.
Совершаем изменения...  
Подготовка...                        #################################################################################################### [100%]
Обновление / установка...
1: viber-alt1.repacked.with.epm.3    #################################################################################################### [100%]
Завершено.