Sisyphus changes — различия между версиями

Материал из ALT Linux Wiki
Перейти к: навигация, поиск
м (Ноябрь: chromium-70.0.3538.77-alt1)
м (убрал 2015/2016 в changes/archive)
Строка 57: Строка 57:
 
Ошибка [https://bugzilla.altlinux.org/32997 32997] с новым rpm при обновлении glibc-locales, если задано ограничение языков через %_install_langs в /etc/rpm/macros.
 
Ошибка [https://bugzilla.altlinux.org/32997 32997] с новым rpm при обновлении glibc-locales, если задано ограничение языков через %_install_langs в /etc/rpm/macros.
 
Временно можно поменять %_install_langs на all и переустановить glibc-locales.
 
Временно можно поменять %_install_langs на all и переустановить glibc-locales.
 
== 2016 ==
 
=== Декабрь ===
 
"'''[https://lists.altlinux.org/pipermail/devel/2016-December/202131.html Пока не обновляйтесь на новый Сизиф:]''' apt сломался из-за линковки со старым liblua, в то время как librpm слинковался с новым." ([https://bugzilla.altlinux.org/show_bug.cgi?id=32931 #32931]) --> '''[https://lists.altlinux.org/pipermail/sisyphus/2016-December/365729.html рецепт исправления]''' с {{pkg|apt-0.5.15lorg2-alt56}} --> '''[https://lists.altlinux.org/pipermail/sisyphus-cybertalk/2016-December/099071.html исправлено] в [https://lists.altlinux.org/pipermail/sisyphus-cybertalk/2016-December/099070.html Sisyphus-20161222]'''
 
 
RPM обновлён до 4.13 (rpm-build это пока не касается); '''обновление rpm и apt [https://lists.altlinux.org/pipermail/sisyphus/2016-December/365678.html рекомендуется] делать с помощью {{cmd|apt-get dist-upgrade}}'''<ref>см. https://lists.altlinux.org/pipermail/sisyphus/2016-December/365691.html</ref>, при этом apt-shell, synaptic, aptitude могут упасть с руганью.
 
 
=== Октябрь ===
 
MATE оказался [https://lists.altlinux.org/pipermail/sisyphus-cybertalk/2016-October/098313.html частично обновлён] до 1.16 (07.10.2016), просьба дождаться завершения обновления (11.10.2016: похоже, уже в достаточной мере добралось).
 
 
=== Июнь ===
 
В Сизиф попал недостаточно протестированный {{pkg|alterator-fbi}} 5.32-alt1.1, это
 
будет исправлено сегодня, но из сегодняшнего Сизифа его обновлять [https://lists.altlinux.org/pipermail/sisyphus/2016-June/365428.html не рекомендуется]. ''(23.06.2016)''
 
 
=== Февраль ===
 
Если при попытке монтирования NFS получаете <tt>mount.nfs: Protocol not supported</tt> -- добавьте в опции монтирования <tt>v3</tt>, умолчание сменилось на NFSv4.
 
 
Если молча перестали писаться логи посредством rsyslog-а (после его обновления) - возможно нужно доустановить rsyslog-classic. См. [https://bugzilla.altlinux.org/show_bug.cgi?id=31819 тикет].
 
 
=== Январь ===
 
 
'''ВАЖНО:''' в {{pkg|openssh-clients-7.1p1-alt1}} по умолчанию [https://lists.altlinux.org/pipermail/sisyphus/2016-January/364679.html выключена поддержка ключей типа ssh-dss] (DSA); рекомендуется отказаться от их использования в пользу<ref>см. тж. рекомендации в статье "[[Работа с ключами разработчика]]"</ref> ED25519, больших RSA (от 2048 бит) либо ECDSA, а при необходимости<ref>...бишь в случае получения сообщения <tt>ssh: Permission denied (publickey).</tt> при {{cmd|control sshd-password-auth disabled}} на сервере либо неожиданном запросе пользовательского пароля, если он на сервере разрешён (по умолчанию)</ref> добавить в соответствующие Host-записи {{path|~/.ssh/config}} разрешение на их использование:
 
 
PubkeyAcceptedKeyTypes +ssh-dss,ssh-dss-cert-v01@openssh.com
 
 
Могут возникнуть проблемы при работе с [http://www.openssh.com/legacy.html устаревшими реализациями SSH] в [https://bugzilla.altlinux.org/show_bug.cgi?id=31716 оборудовании вроде Cisco], при этом следует изучить лог подключения ssh -v и дописать для нужного хоста или группы хостов разрешение:
 
 
KexAlgorithms +diffie-hellman-group1-sha1
 
 
Также в этой сборке учтена уязвимость [http://lists.mindrot.org/pipermail/openssh-unix-dev/2016-January/034680.html UseRoaming].
 
 
== 2015 ==
 
 
=== Декабрь ===
 
В {{pkg|ntp-4.2.8-alt3}} из-за коллизии при установке пропадает {{path|/var/lib/ntpd/etc/services}},  [https://lists.altlinux.org/pipermail/sisyphus/2015-December/364558.html рекомендуется] {{cmd|apt-get reinstall ntpd}} либо {{cmd|update_chrooted conf && service ntpd restart}}; [https://lists.altlinux.org/pipermail/sisyphus/2015-December/364559.html исправлено] в 4.2.8-alt4.
 
 
=== Октябрь ===
 
OTRS 5.0.1 [https://lists.altlinux.org/pipermail/sisyphus/2015-October/364347.html может потребовать] [http://otrs.ru/forum/viewtopic.php?f=2&t=3371 вмешательства] при обновлении с 4.0.13.
 
 
В {{pkg|nvidia_glx_common-352.55-alt155}} [https://lists.altlinux.org/pipermail/sisyphus/2015-October/364339.html добавлен] скрипт {{pkg|nvidia-clean-driver}}, удаляющий ненужные пакеты {{pkg|nvidia_glx_*}}.
 
 
=== Сентябрь ===
 
При обновлении {{pkg|mariadb}} с 5.5.34 до 10.0.21 следует обратить внимание на то, что сборка переведена в чрут аналогично {{pkg|MySQL-server}}; может понадобиться [https://lists.altlinux.org/pipermail/sisyphus/2015-September/364187.html удаление] {{path|/etc/my.cnf.d/server.cnf}}, т.к. рабочим конфигом является {{path|/var/lib/mysql/my.cnf}} (см. тж. вывод {{cmd|/usr/bin/my_print_defaults mysqld}}).
 
 
=== Февраль ===
 
Пользователям {{pkg|xfce4-session}} и {{pkg|xfce4-power-manager}} без {{pkg|systemd}} стоит обратить внимание на [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363465.html анонс майнтейнера] и, возможно, подстроить {{pkg|polkit}}.
 
 
Для {{pkg|kernel-image-un-def}} пока [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363452.html не собирается] модуль nvidia, пользователям соответствующих видеокарт рекомендуется обождать или на 3.18.7, или на std-def. ''346.47 для 3.19.3 собрано''
 
 
Если после обновления {{pkg|nfs-utils}} до 1.3.2 при попытке монтирования NFS получается <tt>mount.nfs: an incorrect mount option was specified</tt> — обратите внимание на [http://lists.altlinux.org/pipermail/sisyphus/2015-February/363371.html рекомендации майнтейнера]. '''NB:''' в случае использования {{pkg|systemd}} в нагрузку можно получить ещё и [https://bugzilla.altlinux.org/show_bug.cgi?id=30708 #30708].
 
 
=== Январь ===
 
Если {{pkg|openvpn}} после обновления до 2.3.6 перестал поднимать туннели из-под {{pkg|etcnet}}, проверьте логи на предмет <tt>'/var/lib/openvpn//tmp/.private/root': No such file or directory</tt> и добавьте в {{path|/etc/net/ifaces/*/ovpnoptions}} строчку <tt>tmp-dir /tmp</tt> для задействования {{path|/var/lib/openvpn/tmp}} (более не требуется с {{pkg|etcnet}} >= 0.9.10-alt18).
 
  
 
== Ссылки ==
 
== Ссылки ==

Версия 10:31, 12 февраля 2019

50px-Gnome globe current event.png
Данная статья периодически обновляется.
Последнее обновление
10:31 12 февраля 2019

Замечания об обновлении Sisyphus

Zn1 26.gif Здесь собираются важные замечания, связанные с обновлением системы из Sisyphus; обновления по безопасности отмечаются на этой страничке.

Пожалуйста, если вносите предупреждения заранее, то потом либо убирайте их, либо конкретизируйте проблему. Извещения «месяц назад надо было бояться» бесполезны.

Старые по меркам Сизифа замечания накапливаются в архиве.

Рекомендации

2018

Ноябрь

Похоже, chromium-70.0.3538.67, ушедший вчера в сизиф, оказался сломанным. Не обновляйтесь на него. (исправлено в 70.0.3538.77-alt1)

Сентябрь

Не стоит спешить с обновлением ответственных систем, в сизифе происходит переезд на openssl 1.1 и может потряхивать на ухабах.

Июль

Если на хост-системе установлены xorg-drv-vboxvideo и virtualbox-guest-additions -- их лучше удалить во избежание проблемы вида "OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM"; altbug #35170

Июнь

Владельцам видеокарт NVIDIA предлагается быть внимательными до обновления: 1.06.2018 в сизиф приехал xorg-server 1.20, с которым пока не работает фирменный драйвер nvidia.

Май

Сборка ImageMagick в сизифе за 31.05.2018 немного недоработана, обновление стоит производить с предварительным apt-get install libImageMagick6 libImageMagick- или уже летом.

Апрель

В сизиф отправлен systemd-238-alt4 с включенным по умолчанию default-kill-user-processes=true во избежание "залипаний" на пользовательских процессах при выключении/перезагрузке; при этом и фоновые процессы вроде screen/tmux на машинах под управлением systemd также станут уничтожаться при выходе пользователя -- варианты решения по ссылке (плюс sysvinit).

Февраль

01.02.2018 выложено ядро kernel-image-ovz-el-2.6.32-alt162 с решением проблемы поддержки glibc на x86_64. На i586 проблема до сих пор остаётся (bug 34556).

2017

Декабрь

22.12.2017 Сизиф перешёл на glibc 2.26, который требует ядро 3.2 и выше, поэтому его работа на ядрах 2.6.32-ovz-el (и в OpenVZ-контейнерах) сломалась.

Июнь

Системы, использующие grub-efi, рекомендуется не обновлять, пока не будет исправлена 33564, иначе возможно получить незагружаемую систему.

Февраль

Просьба дождаться обновления lua5.1 до сборки 5.1.5-alt5, в -alt4 есть необъявленный конфликт, ломающий dist-upgrade.

Январь

systemd-232-alt1 не работает на i586 -- избегайте обновления 32-битных систем до этой версии; исправление доступно в сборке 232-alt2.git.486b3d0 (ожидается на ftp 4.02.2017, сборочное задание 177580).

dhcp-server-4.3.3-alt4 не отвечает не запросы, помогает откат на -alt3. Обсуждается в 33053. Сломанную сборку успели портировать в p8.

При обновлении хостов под управлением systemd до 232-alt1 использующим контейнерную виртуализацию следует обратить внимание на это письмо.

Ошибка 32997 с новым rpm при обновлении glibc-locales, если задано ограничение языков через %_install_langs в /etc/rpm/macros. Временно можно поменять %_install_langs на all и переустановить glibc-locales.

Ссылки