Hold: различия между версиями

Материал из ALT Linux Wiki
Перейти к навигации Перейти к поиску
 
(не показано 5 промежуточных версий 3 участников)
Строка 2: Строка 2:
Бывает нужно, чтобы при установке обновлений не затрагивались какие-либо пакеты — или известны регрессии в новой версии (о чём стоит сообщить сборщику пакета или разработчикам программы), или стоит сборка с иными патчами (о чём тоже хорошо бы уведомить майнтейнера).
Бывает нужно, чтобы при установке обновлений не затрагивались какие-либо пакеты — или известны регрессии в новой версии (о чём стоит сообщить сборщику пакета или разработчикам программы), или стоит сборка с иными патчами (о чём тоже хорошо бы уведомить майнтейнера).


При использовании менеджера пакетов [[APT]] этого можно достигнуть указанием в файле {{path|/etc/apt/apt.conf}}:
При использовании менеджера пакетов [[APT]] этого можно достигнуть созданием файла {{path|/etc/apt/apt.conf.d/hold-нужное.conf}} вида
RPM::Hold { "^имя_пакета"; }
<pre>
либо добавлением строчки в секцию
/* held due to problems with this package in sisyphus as of 20150323 -- mike@ */
RPM::Hold {
        "^имя_пакета";
};
</pre>
 
либо добавлением в файле {{path|/etc/apt/apt.conf}} строчки в секцию
  RPM
  RPM
  {
  {
Строка 12: Строка 18:
  };
  };


Обратите внимание: строчки являются ''регулярными выражениями'', т.е. при необходимости можно захолдить сразу несколько пакетов:
Обратите внимание: строчки являются ''регулярными выражениями'', т.е., при необходимости, можно захолдить сразу несколько пакетов:
  "^FlightGear.*";
  "^FlightGear.*";


Не забывайте про точки запятой в конце строки!
Из-за этого же, перед именем, всегда стоит указывать символ начала строки "^". Не забывайте про точки с запятой в конце строки!
 
= Ограничение =
 
Hold не препятствует обновлению по зависимостям: {{altbug|18636}}.


== См. тж. ==
== См. тж. ==
* [[APT в ALT Linux/aptitude]]
* [[APT в ALT Linux/aptitude]]
* [[APT в ALT Linux/Советы по использованию]]


{{Category navigation|title=APT|category=APT|sortkey={{SUBPAGENAME}}}}
{{Category navigation|title=APT|category=APT|sortkey={{SUBPAGENAME}}}}
[[Категория:APT]]
[[Категория:APT]]

Текущая версия от 12:54, 31 января 2019

Как «поставить пакеты на холд»[править]

Бывает нужно, чтобы при установке обновлений не затрагивались какие-либо пакеты — или известны регрессии в новой версии (о чём стоит сообщить сборщику пакета или разработчикам программы), или стоит сборка с иными патчами (о чём тоже хорошо бы уведомить майнтейнера).

При использовании менеджера пакетов APT этого можно достигнуть созданием файла /etc/apt/apt.conf.d/hold-нужное.conf вида

/* held due to problems with this package in sisyphus as of 20150323 -- mike@ */
RPM::Hold {
        "^имя_пакета";
};

либо добавлением в файле /etc/apt/apt.conf строчки в секцию

RPM
{
   Hold {
   // ...
   };
};

Обратите внимание: строчки являются регулярными выражениями, т.е., при необходимости, можно захолдить сразу несколько пакетов:

"^FlightGear.*";

Из-за этого же, перед именем, всегда стоит указывать символ начала строки "^". Не забывайте про точки с запятой в конце строки!

Ограничение[править]

Hold не препятствует обновлению по зависимостям: altbug #18636.

См. тж.[править]