Changes/archive — различия между версиями

Материал из ALT Linux Wiki
Перейти к: навигация, поиск
(Import from freesource.info)
 
м (Архив замечаний по Сизифу: 2015, 2016)
(не показано 6 промежуточных версий этого же участника)
Строка 1: Строка 1:
 
[[Category:Sisyphus]]
 
[[Category:Sisyphus]]
{{MovedFromFreesourceInfo|AltLinux/Sisyphus/changes/archive}}
+
{{Викифицировать}}
  
 
== Архив замечаний по Сизифу ==
 
== Архив замечаний по Сизифу ==
  
__TOC__
+
=== [[Changes/archive/2016|2016]] ===
 +
=== [[Changes/archive/2015|2015]] ===
 +
=== [[Changes/archive/2014|2014]] ===
 +
=== [[Changes/archive/2013|2013]] ===
 +
=== [[Changes/archive/2012|2012]] ===
 +
=== [[Changes/archive/2011|2011]] ===
 +
=== [[Changes/archive/2010|2010]] ===
 +
=== [[Changes/archive/2009|2009]] ===
 +
=== [[Changes/archive/2008|2008]] ===
 +
=== [[Changes/archive/2007|2007]] ===
 +
=== [[Changes/archive/2006|2006]] ===
 +
=== [[Changes/archive/2005|2005]] ===
 +
=== [[Changes/archive/2004|2004]] ===
  
=== 2007 ===
+
[[Категория:Changes]]
==== Декабрь ====
 
'''31.12.2007'''
 
Вследствие недосмотра мейнтейнера в Сизифе оказался пакет <div style="display: inline; color: red;">gnome-games-2.20.0.1</div> с нерабочим %preun-скриптом. Что вызывает проблемы при обновлении/удалении пакета gnome-games-common (версии 2.20.0.1-alt1). В случае, если у Вас таковой
 
установлен, для удаления потребуется воспользоваться `rpm -e --noscripts gnome-games-common`.
 
(При dist-upgrade будет поставлен новый gnome-games-common (версии 2.20.2-alt1, в которой этот баг исправлен), но не удалён старый.)
 
 
 
==== Ноябрь ====
 
'''21.11.2007'''
 
Мейнтейнер КДЕ [http://lists.altlinux.org/pipermail/community/2007-November/399782.html предупреждает], что с версии <div style="display: inline; color: red;">kde-settings</div> > 3.5.8-alt1 и <div style="display: inline; color: red;">kdebase</div> > 3.5.8-alt2 изменились некоторые умолчательныенастройки в конфигурации рабочего стола и панели. Вместо иконок устройств на рабочем столе -- апплет сменных устройств на панели.
 
 
 
'''14.11.2007 '''
 
[http://lists.altlinux.org/pipermail/devel/2007-November/066218.html Предупреждают] об отправлении в сизиф <div style="display: inline; color: red;">util-linux</div>-ng.
 
 
 
==== Октябрь ====
 
''' 17.10.2007 '''
 
Лучше избежать обновления до <div style="display: inline; color: red;">libgtk+2-2.12.0-alt1</div> -- вылазят [http://lists.altlinux.org/pipermail/sisyphus/2007-October/208656.html неприятности], исправленные в [https://bugzilla.altlinux.org/show_bug.cgi?id=13124 2.12.0-alt2].
 
 
 
==== Сентябрь ====
 
'''25.09.2007'''
 
[https://lists.altlinux.org/pipermail/sisyphus/2007-September/208019.html Объявлено], что <div style="display: inline; color: red;">kernel-modules-nvidia-legacy</div> больше нет -- модули внесены в <tt>kernel-modules-nvidia</tt>.  Хорошо бы потестировать.
 
 
 
'''24.09.2007'''
 
В Sisyphus отправлена библиотека <div style="display: inline; color: red;">libgnomekbd-2.20.0-alt1</div>. После её обновления и до перезапуска X.Org перестанет работать индикатор раскладки в GNOME. Другими словами, после обновления этой библиотеки рекомендуется перезапустить иксы.
 
 
 
'''18.09.2007'''
 
Майнтейнер <div style="display: inline; color: red;">dbmail</div> [http://lists.altlinux.org/pipermail/sisyphus/2007-September/207767.html предупреждает], что версия 2.2.6 -- официально нерабочая (upstream), а сборка не прошла обычного предварительного тестирования. (на следующий день ушла 2.2.7RC1)
 
 
 
''' 14.09.2007'''
 
В <div style="display: inline; color: red;">xorg-x11-server-1.4-alt2</div> оказался по умолчанию включен Composite, с которым не живёт (совсем) <div style="display: inline; color: red;">wdm</div> и глючит (дико) <div style="display: inline; color: red;">WindowMaker</div>.  Для отключения необходимо явное указание в <tt>/etc/X11/xorg.conf</tt> следующего (майнтейнер в курсе, грозится исправить за xorg'овских):
 
<pre>Section "Extensions"
 
        Option  "Composite"    "false"
 
EndSection</pre>
 
 
 
Если используется драйвер "nvidia" и отваливается с сообщением об изменении версии ABI, в качестве временного workaround можно добавить <tt>-ignoreABI</tt> в <tt>/etc/X11/xinit/xserverrc</tt> (для gdm -- в [http://lists.altlinux.org/pipermail/sisyphus/2007-September/207626.html /etc/X11/gdm/custom.conf]) -- или <tt>Option &quot;IgnoreABI&quot; &quot;true&quot;</tt> в <tt>ServerLayout</tt>.
 
 
 
''' 13.09.2007 '''
 
После небольшой задержки на нас свалился новый Сизиф, в котором сломалось переключение раскладок. Мантейнер xorg сообщил, что всё понял, и надо ждать <tt>xorg-x11-server-1.4</tt>.
 
 
 
''' 04.09.2007 '''
 
В sisyphus@ предупреждают, что <div style="display: inline; color: red;">/etc/X11/fs/config</div> переезжает из setup в xorg-x11-xfs и лучше на всякий сделать резервную копию этого файла.
 
 
 
==== Август ====
 
''' 31.08.2007 '''
 
Майнтейнер <div style="display: inline; color: red;">xorg</div>, оказывается, [http://lists.altlinux.org/pipermail/devel/2007-August/049689.html предупреждал], что вместо <tt>FontPath &quot;unix/:-1&quot;</tt> в <tt>/etc/X11/xorg.conf</tt> после производимого изменения положено <tt>FontPath "catalogue:/etc/X11/fontpath.d"</tt>. ([http://lists.altlinux.org/pipermail/devel/2007-August/062415.html Предложение] вообще удалить опцию <tt>FontPath</tt> вместе с включающей её секцией <tt>Files</tt> может сработать или нет в зависимости от того, насколько нов пакет <div style="display: inline; color: red;">xorg-x11-server</div> у Вас.)  Если иксы не стартуют -- придётся править руками :-/
 
 
 
==== Апрель ====
 
''' 10.04.2007 '''
 
Igor Zubkov [http://lists.altlinux.org/pipermail/sisyphus/2007-April/096772.html предупредил] что после обновления с любой старой версии openbox до 3.3.1-alt3 или выше слетает меню. Надо сделать следущее что бы вернуть:
 
cd /
 
cd .config/
 
mv openbox openbox.old
 
Конечно, эти команды надо запускать при не запущем openbox.
 
 
 
Mike Shigorin [http://lists.altlinux.org/pipermail/devel/2007-April/044717.html пожаловался] что свежее ядро 2.6.18-ovz-smp-alt13 на x86_64 сломано. Помог откат на 2.6.18-ovz-smp-alt12. На i586 не [http://lists.altlinux.org/pipermail/devel/2007-April/044788.html воспроизводится]. ''mike: у меня и на x86_64 уже не воспроизводится, хотя сегодня же довольно swsoft спешно выкатили новый openvz patch''
 
 
 
''' 05.04.2007 '''
 
Дмитрий Левин [http://lists.altlinux.org/pipermail/sisyphus/2007-April/096282.html попросил] морально подготовиться к обновлению <div style="display: inline; color: red;">OpenSSH</div> с 3.6.1p2-alt10 до 4.6p1-alt1.  ''Не прошло и 4-х лет, изменений немало.''  Из замеченного: [http://lists.altlinux.org/pipermail/devel/2007-April/044588.html ssh -X/-Y]
 
 
 
''' 01.04.2007 '''
 
Сергей Иванов [http://lists.altlinux.org/pipermail/sisyphus/2007-April/095891.html предупредил], что инитскрипт <div style="display: inline; color: red;">dovecot</div>, отправленного в incoming, содержит ошибку, которая  приводит к ложному сообщению о неудаче при каждом старте dovecot, если сертификаты уже сгенерированы.
 
 
 
==== Март ====
 
''' 30.03.2007 '''
 
Sergey Vlasov с выражением [http://lists.altlinux.org/pipermail/sisyphus/2007-March/095764.html зачитал] <tt>--lastchange</tt> <div style="display: inline; color: red;">udev-108-alt1</div>.  При заметных внутренних изменениях внешних проявлений вроде бы минимум.
 
 
 
''' 03.03.2007 '''
 
Sergey Vlasov сообщает ([http://lists.altlinux.org/pipermail/sisyphus/2007-February/093200.html 1], [http://lists.altlinux.org/pipermail/sisyphus/2007-March/094292.html 2]), что для обновления пакета <div style="display: inline; color: red;">dev</div>, при установленном и запущенном <div style="display: inline; color: red;">udevd</div> надо дать команду  <tt>service udevd umount</tt> (dev-3.3.1-alt18 подскажет то же самое).
 
 
 
''' 02.03.2007 '''
 
Alexey Shabalin [http://lists.altlinux.org/pipermail/sisyphus/2007-March/094201.html сообщает] о [http://rt.cpan.org/Public/Bug/Display.html?id=24835 наличии проблем] в <div style="display: inline; color: red;">perl-libnet</div>, что чревато при использовании <div style="display: inline; color: red;">amavisd-new</div> ("получаемые письма странно перекодируются"). Не обновляйте perl-libnet до 1.20-alt1 [https://bugzilla.altlinux.org/show_bug.cgi?id=10976 #10976]
 
 
 
==== Февраль ====
 
''' 16.02.2007 '''
 
ldv@ [http://lists.altlinux.org/pipermail/sisyphus/2007-February/093630.html сообщает], что между обновлением <div style="display: inline; color: red;">startup</div> и <div style="display: inline; color: red;">udev</div> при нежелании видеть мусор при загрузке может захотеться временно добавить в параметры ядра <tt>noudev</tt>.
 
 
 
'''08.02.2007'''
 
Сергей Власов [http://lists.altlinux.org/pipermail/devel/2007-February/041647.html предвещает] скорую смерть <div style="display: inline; color: red;">hotplug</div> как класса, заменяя его более функциональным <div style="display: inline; color: red;">udev</div> . Версия 105 несет массу нововведений и улучшений. Будьте бдительны. Особенно это коснется hotplug'овского blacklist'а.
 
 
 
 
 
==== Январь ====
 
'''30.01.2007'''
 
Сергей Власов [http://lists.altlinux.org/pipermail/sisyphus/2007-January/092482.html анонсировал] переезд ALT Linux с варианта modutils имени ApplianceWare (с добавленной поддержкой Linux 2.6) на "майнстримовый" <div style="display: inline; color: red;">module-init-tools</div>.  Несмотря на массу предпринятых предосторожностей, следует ознакомиться с этим сообщением.
 
 
 
''' 24.01.2007'''
 
В связи с выносом некоторых модулей GNOME VFS в отдельные пакеты при обновлении пакета <div style="display: inline; color: red;">gnome-vfs</div> следует также доустановить следующие пакеты:
 
* если вы пользуетесь Windows shares (протокол SMB/CIFS), вам следует установить пакет '''gnome-vfs-module-smb''';
 
* если вы пользуетесь доступом по SSH/SFTP, вам следует установить пакет '''gnome-vfs-module-sftp''';
 
И обратное: если вы /не/ пользуетесь доступом по протоколам SMB/CIFS, можете попробовать удалить libsmbclient :)
 
аналогично, если вам не нужна функциональность клиента SSH, можете попробовать удалить openssh-clients :)
 
Новая версия <div style="display: inline; color: red;">gnome-sisyphus-default</div> требует эти два модуля. <div style="display: inline; color: red;">gnome-sisyphus-minimal</div> *не требует* их.
 
 
 
''' 11.01.2007 '''
 
<s>В /i/S [http://lists.altlinux.org/pipermail/sisyphus/2007-January/091528.html отправляется] маленькая часовая бомба в виде пары пакетов <div style="display: inline; color: red;">librsvg</div>-2.16.1-alt2 и <div style="display: inline; color: red;">librsvg-gnome</div>-2.16.1-alt2...</s>Бомба обезврежена благодаря сапёру ldv@. Пакета librsvg-gnome в репозитории больше нет, он оказался неустанавливаемым.
 
 
 
=== 2006 ===
 
==== Декабрь ====
 
''' 27.12.2006 '''
 
Если у кого-то после обновления не запускается k3b то надо просто отодвинуть в сторону .rcc. [https://bugzilla.altlinux.org/show_bug.cgi?id=10428 Подробности].
 
 
 
''' 22.12.2006 '''
 
[http://lists.altlinux.org/pipermail/devel/2006-December/039917.html Объявлено], что изменения в пакетах <div style="display: inline; color: red;">apache</div>-1.3.37rusPL30.22-alt9, <div style="display: inline; color: red;">collectd</div>-3.10.3-alt1 и <div style="display: inline; color: red;">monit</div>-4.8.2-alt3 приведут к тому, что сервисы <div style="display: inline; color: red;">httpd</div>, <div style="display: inline; color: red;">httpd-perl</div>, <div style="display: inline; color: red;">collectd</div> и <div style="display: inline; color: red;">monit</div> отныне "из коробки" будут выключены.  Если кто вдруг не знал, как пользоваться chkconfig(8) -- самое время узнать :)
 
 
 
''' 21.12.2006'''
 
В Сизиф отправляется свежий [http://lists.altlinux.org/pipermail/sisyphus/2006-December/090953.html dbus]. Просьба воздержатся от обновления приложений который зависят от него пока большая часть их не будет пересобрана с новым dbus.
 
 
 
Майнтейнер <div style="display: inline; color: red;">mount</div> [http://lists.altlinux.org/pipermail/sisyphus/2006-December/090951.html предупреждает] о том, что в сборке mount-2.12r-alt4 две старые крупные грабли заменяет одна мелкая -- для новых установок пакета <div style="display: inline; color: red;">portmap</div> сервис <tt>portmap</tt> будет по умолчанию выключен. ''(как по мне, так совсем и не грабля)''
 
 
 
''' 11.12.2006'''
 
Новые ядра (2.6.18) располагаются в пакетах kernel-image-std-pae (для серверов с процессорами i686+, поддерживающими [http://lists.altlinux.org/pipermail/devel/2006-November/039106.html PAE]) и kernel-image-std-smp (для рабочих станций и ноутбуков, включая SMP i586 и "старые" Pentium M с FSB400, которые PAE не умеют).  SMP поддерживают оба варианта.  Вледствие переименования (убран неактуальный суффикс <tt>26</tt>) обновление следует провести вручную.
 
 
 
''' 03.12.2006'''
 
Начиная с mount 2.12r-alt2, из него вынесена поддержка NFS во внешний модуль mount.nfs. Так что для монтирования NFS потребуется поставить пакет <div style="display: inline; color: red;">nfs-clients</div>. Диагностика: <tt>E: Couldn't find package nfs-client</tt>
 
 
 
==== Ноябрь ====
 
''' 30.11.2006 '''
 
[http://lists.altlinux.com/pipermail/sisyphus/2006-November/089909.html Предупреждают], что <div style="display: inline; color: red;">PolicyKit-0.2-alt4.git20060822</div> лучше не устанавливать вследствие недовытоптанных грабель неуточнённого характера.
 
 
 
''' 27.11.2006 '''
 
Майнтейнер <div style="display: inline; color: red;">vzctl</div> переправляет предупреждение, что сборка 3.0.13-alt1 несколько сломана, и [http://lists.altlinux.com/pipermail/sisyphus/2006-November/089708.html рекомендует] дождаться -alt2.
 
 
 
В incoming отправлен <div style="display: inline; color: red;">MySQL41</div> 4.1.21-alt5. Владельцы <div style="display: inline; color: red;">MySQL</div>, если при dist-upgrade эта.. вещь.. попытается заменить ваш любимый <div style="display: inline; color: red;">MySQL</div> 5.0 - не верьте. Ставьте на холд,  вешайте блокер багу и пишите в личку gns@/hiddenman@. Этого не должно происходить и на моих хостах не наблюдается, но мало ли.
 
При явном <div style="display: inline; color: red;">apt-get install [[changes/MySQL41|MySQL41]]-server</div> выносятся <div style="display: inline; color: red;">MySQL</div> любых других версий, и наоборот. Так и задумано. Проблема в том, что совместимость бинарных баз между версиями не гарантируется, поэтому при изменении версии надо дампить, отодвигать в сторонку /var/lib/mysql и загружать дамп.
 
Заинтересованные - тестируйте.
 
 
 
Если после обновления <div style="display: inline; color: red;">libqt4</div> вдруг полезли совсем уж иероглифы, [http://lists.altlinux.org/pipermail/devel/2006-November/038982.html поможет] <tt>rm -f ~/.config/[[changes/Trolltech.conf|Trolltech.conf]]</tt>
 
 
 
''' 07.11.2006'''
 
<div style="display: inline; color: red;">bluez-utils</div>: в связи с исправлением [https://bugzilla.altlinux.org/show_bug.cgi?id=8885 #8885] после обновления до 3.7-alt1 необходимо (ну, необязательно, но это мусор) вручную удалить каталог /var/lib/lib/bluetooth либо перенести его содержимое в /var/lib/bluetooth (обращаю внимание, что в этом каталоге, в частности, содержатся ключи спаренных устройств).
 
 
 
Майнтейнер <div style="display: inline; color: red;">MySQL</div> [http://lists.altlinux.org/pipermail/sisyphus/2006-November/088830.html обращает внимание] на изменения и дополнения в сборке 5.0.27-alt1, которые хорошо бы проверить в разных ситуациях.
 
 
 
''' 03.11.2006 '''
 
Майнтейнер <div style="display: inline; color: red;">KDE</div> [http://lists.altlinux.org/pipermail/sisyphus/2006-November/088623.html предупреждает]: "с обновлением до kdelibs-3.5.5-alt3 возможно подвисание KDE при завершении его работы. Рекомендуется завершить работу KDE до обновления. Если забудете, то Ctrl+Alt+Backspace. Если не поможет, то Ctrl+Alt+F1,Ctrl+Alt+Del"
 
 
 
==== Октябрь ====
 
''' 24.10.2006 '''
 
В сизифе обновилась <div style="display: inline; color: red;">libdb4</div> -- по крайней мере на <div style="display: inline; color: red;">amarok</div>, <div style="display: inline; color: red;">kaffeine</div> и <div style="display: inline; color: red;">xmms</div> это проявилось так, что требуется [http://lists.altlinux.org/pipermail/sisyphus/2006-October/088102.html отодвинуть в сторону]  <tt>~/.rcc</tt>, чтобы <div style="display: inline; color: red;">librcc</div>, с которой собрана <div style="display: inline; color: red;">libtag</div>, не попадала впросак при запуске.
 
 
 
''' 19.10.2006 '''
 
Сообщается, что сизифовый <div style="display: inline; color: red;">wine</div>-20060902-alt2 segfault'ится на старте.  Майнтейнер [http://lists.altlinux.org/pipermail/sisyphus/2006-October/087843.html в курсе].  При срочной  необходимости можно откатиться на <tt>alt1</tt> или взять [http://lists.altlinux.org/pipermail/sisyphus/2006-October/087844.html работающую сборку] [http://winehq.org.ru/ здесь].
 
 
 
''' 04.10.2006 '''
 
'''Майнтейнер <div style="display: inline; color: red;">glibc</div> [http://lists.altlinux.org/pipermail/sisyphus/2006-October/087266.html предупреждает] по поводу перехода на 2.5: "будьте внимательны при осуществлении этого обновления. ''С сегодняшнего дня в Сизифе ядро 2.4 официально больше не поддерживается.'' Попытка установить glibc-2.5-alt1 в систему, работающую под управлением ядра версии <2.6.9, приведёт такую систему в нерабочее состояние." (диагностика: при запуске чего угодно, динамически с ней слинкованного -- <tt>FATAL: kernel too old</tt>)'''
 
''уже [http://lists.altlinux.org/pipermail/sisyphus/2006-October/087304.html замечены] и [http://lists.altlinux.org/pipermail/sisyphus/2006-October/087338.html идентифицированы] грабли с Driver "nvidia" и включенным glx''
 
 
 
==== Сентябрь ====
 
'''29.09.2006'''
 
Не следует пугаться строк или страниц вывода при обновлении <div style="display: inline; color: red;">dev</div>.  Подробности [http://lists.altlinux.org/pipermail/sisyphus/2006-September/087139.html письмом], вкратце -- майнтейнер не видит возможности сделать иначе или надёжно автоматизировать
 
<pre>service udevd stop
 
apt-get install dev
 
service udevd start
 
service syslogd restart</pre>
 
 
 
'''27.09.2006'''
 
Всем кто ещё не обновил GNOME (в частности, пакеты <div style="display: inline; color: red;">gnome-control-center</div> и <div style="display: inline; color: red;">gnome-session</div>) до версии 2.15/2.16, настоятельно рекомендуется дождаться появления в Сизифе пакета gnome-session-2.16.0-alt2, чтобы избежать проблем с применением различных общедесктопных настроек (в частности, оформления рабочего стола). Те, кто уже налетел на эти грабли, могут исправить скрипт /usr/bin/startgnome2, добавив запуск dbus-launch как указано [http://lists.altlinux.org/pipermail/sisyphus/2006-September/087037.html в этом письме]
 
 
 
'''15.09.2006'''
 
Тем кто обновил KDE до 3.5.4 рекомедуется обновится до alt4 сборки. [http://lists.altlinux.org/pipermail/sisyphus/2006-September/086699.html Подробности]
 
 
 
'''11.09.06'''
 
Счастливчикам которые обновили php до 4.4.4-alt1 и у которых всё php-шное перестало работать -- рецепт таблеток от кашля. [http://lists.altlinux.org/pipermail/sisyphus/2006-September/086450.html часть 1] [http://lists.altlinux.org/pipermail/sisyphus/2006-September/086449.html часть 2] [http://lists.altlinux.org/pipermail/sisyphus/2006-September/086452.html часть 3].
 
 
 
'''08.09.06'''
 
С <div style="display: inline; color: red;">ncurses</div> (апстримом, на самом деле) наблюдаются странности, эффект которых схож с сведением терминала с ума бинаркой.  Пока [http://lists.altlinux.org/pipermail/devel/2006-September/036142.html разбираются] с апстримом и исправлением в сизифе, можно взять [http://bugzilla.redhat.com/202480 исправленные] пакеты у [ftp://ftp.altlinux.ru/pub/people/abulava/repo.ncurses-5.5-alt3.1 abulava@].
 
 
 
'''03.09.06'''
 
Поскольку пакеты из GNOME 2.16 появляются в Сизифе постепенно, и из-за этого могут быть несогласованы друг с другом, настоятельно рекомендуется воздержаться от апгрейда пакетов <div style="display: inline; color: red;">GNOME</div> в ближайшие несколько дней. Следите за новостями.
 
 
 
'''02.09.06'''
 
В KDE наблюдается падение kdesktop после апдейта. Решения:
 
1. Тупое: mv ~/.kde/share/config/kdesktoprc /.kde/share/config/kdesktoprc.old
 
2. Более хитрое: найти в ~/.kde/share/config/kdesktoprc строчку:
 
<pre>Preview=audio/,imagethumbnail,exrthumbnail,textthumbnail,djvuthumbnail,htmlthumbnail,cursorthumbnail,fontthumbnail</pre>
 
и заменить ее на
 
<pre>Preview=audio,imagethumbnail,exrthumbnail,textthumbnail,djvuthumbnail,htmlthumbnail,cursorthumbnail,fontthumbnail</pre>
 
т.е. убрать "/" после audio.
 
 
 
==== Август ====
 
'''13.08.06'''
 
Пакеты <div style="display: inline; color: red;">libpango 1.14.0, libgtk+2 2.10.1 и gtk-engines-* 2.7.6</div>, которые скоро окажутся в Сизифе, желательно обновлять все вместе. Аналогично gnome-themes-*, перед обновлением
 
крайне желательно проверить, что текущая тема Gtk+ не использует устаревший engine ('''Metal и Lighthouse Blue''' в gtk-engines-default больше нет). После обновления может понадобиться перезапустить все Gtk-приложения (в том числе GNOME, особенно его панель). Это замечание (пока) не касается пользователей x86_64&nbsp;&mdash; на этой архитектуре не собрался пакет libpango, следовательно, и Gtk+ обновлять пока не стоит.
 
 
 
В связи с появлением Cairo 1.2.2, два замечания для пользователей <div style="display: inline; color: red;">gswitchit-plugins</div>:
 
* Если вы используете флаги для индикатора раскладок&nbsp;&mdash; с новым Cairo флаги показываться не будут.
 
* Если вы используете плагин анимации для индикатора раскладок&nbsp;&mdash; отключите его, с новым Cairo он приводит к падению индикатора (это не связано с Gtk+, только с Cairo). Если вы уже налетели на эти грабли, запустите программу gswitchit-plugins-capplet и удалите плагин.
 
 
 
P.S. Особое замечание для пользователей x86_64: на вашей архитектуре новый libpango, увы, не собрался, соответственно, не стоит пока обновлять и Gtk+.
 
 
 
'''11.08.06'''
 
Настоятельно рекомендуется перед обновлением пакетов <div style="display: inline; color: red;">metacity-themes-* и gnome-themes-*</div> проверить, что текущие темы на вашем рабочем столе не будут удалены. Список тем (и для Gtk+, и для Metacity), которые <u>прекратили</u> своё существование в Сизифе: '''Grand Canyon, Sandy, Sandwish, Simple, Smokey, Traditional, Ocean Dream'''.
 
 
 
'''10.08.06'''
 
<s>Подозреваются серьёзные грабли в районе <div style="display: inline; color: red;">libglade-2.6.0</div>, приводящие к неработоспособности GNOME и приложений, использующих эту библиотеку. Рекомендуется временно воздержаться от обновления пакета libglade.</s>libglade вне подозрений
 
 
 
==== Июнь ====
 
'''29.06.06'''
 
В переименованном <div style="display: inline; color: red;">mod_php</div> (который теперь <div style="display: inline; color: red;">apache-mod_php</div>) найдены недобитые [http://lists.altlinux.org/pipermail/sisyphus/2006-June/083650.html остатки былого]: ''Раскопки показали, что mod_php по новым путям даже не смотрит и вообще никакие ini файлы в дереве /etc/php/4.4.3/apache-mod_php/ не считывает. Скопировал все конфиги руками в /etc/php/4.4.3/mod_php/ -- все заработало'', а также [http://lists.altlinux.org/pipermail/sisyphus/2006-June/083645.html излишества нового]: ''обновление прописывает неверные пути в php.ini -- с добавлением повсюду '.cvs2006' после '4.4.3', хотя на самом деле такого суффикса в файловой системе не наблюдается''.
 
 
 
'''23.06.06'''
 
в первый же день тестирования выложенной вчера в Сизиф версии <div style="display: inline; color: red;">dovecot</div> обнаружилась одна неприятная черта, см
 
[https://bugzilla.altlinux.org/show_bug.cgi?id=9719 https://bugzilla.altlinux.org/show_bug.cgi?id=9719]
 
Поэтому, желающие обновить dovecot, если у вас уже есть базы почтовых сообщений, будьте осторожны.
 
Особенно если с его mailfolder'ами что-то делали помимо dovecot'а (то есть подкладывали ему туда почту от других серверов при помощи rsync,
 
scp, mv, cp и т.п).
 
В ближайшее время в incoming/Sisyphus будет направлена версия dovecot без самых последних изменений, вызвавших эту трудность.
 
 
 
'''14.06.06'''
 
В настоящее время пакет <div style="display: inline; color: red;">libsmbclient</div> сломан из-за нового [[changes/OpenLDAP|OpenLDAP]], пришедшего в Сизиф. Фикс ожидается на следующей неделе, в качестве временного решения для собирающих пакеты была выпущена сборка <div style="display: inline; color: red;">gnome-vfs</div> без поддержки Samba shares. Если вы не хотите потерять поддержку Samba в GNOME, не обновляйте этот пакет!
 
 
 
'''06.06.06'''
 
Тем, кто испытывает трудности с обновлением тех или иных частей <div style="display: inline; color: red;">GNOME</div>, или программ, использующих библиотеки из GNOME, рекомендуется прежде всего отдельно обновить пакеты, избавившиеся от двойки в названии. Поскольку в зависимостях используются названия с двойкой, а APT предпочитает точное совпадение с названием пакета совпадению с одним из Provides, эти пакеты автоматически обновляться не умеют. Это касается gnome-vfs(2), gnome(2)-media, gnome(2)-utils,  libgnomeprint(2), libbonobo(2), libeel(2), nautilus(2) и ряда других пакетов из GNOME(2).
 
 
 
'''04.06.06'''
 
Если после обновления <div style="display: inline; color: red;">CUPS</div> у вас всё работает кроме [[changes/OpenOffice|OpenOffice]] и Firefox, внесите пользователя в группу lp. (спасибо mithraen@ за указание на /var/run/cups/cups.sock)
 
 
 
''' 02.06.2006 '''
 
<div style="display: inline; color: red;">emacs-planner-mode-3.40-alt1</div> был переписан с использованием emacs-muse-mode. Необходимы изменения в конфигурации, для сохранения задач, созданных предыдущими версиями emacs-planner-mode, необходимо переименовать plan-файлы. Подробности [http://lists.altlinux.org/pipermail/sisyphus/2006-June/082628.html здесь]
 
 
 
 
 
==== Май ====
 
''' 29.05.2006 '''
 
Мейнтейнер <div style="display: inline; color: red;">polypaudio</div> без объяснения причин рекомендует поставить пакет на hold и через 2-3 дня hold снять.
 
 
 
''' 26.05.2006 '''
 
lav@: Очень мил changelog к <div style="display: inline; color: red;">CUPS</div>, содержащий лишь "1.2.1". После обновления мне пришлось скопировать конфиг из rpmnew, потому что на старый он ругался (кстати, конфиг, идущий с пакетом, стал в 10 раз короче) и настроить все принтеры заново. Будьте осторожны.
 
 
 
''' 23.05.2006 '''
 
shrek@ [http://lists.altlinux.org/pipermail/devel/2006-May/032986.html предупреждает], что вышел X11R7.1 и сейчас не только традиционно отвалился <div style="display: inline; color: red;">fglrx</div>, но и <div style="display: inline; color: red;">nvidia</div>.  rider@ предложил подержать в Daedalus до обновления проприетарных драйверов.
 
 
 
''' 20.05.2006 '''
 
vsu@ анонсирует выпуск <div style="display: inline; color: red;">kernel-image-std26-up-2.6.16-alt5</div> и [http://lists.altlinux.org/pipermail/sisyphus/2006-May/081939.html акцентирует] внимание владельцев Intel-чипсетов, особенно имени ASUS, что могут отвалиться сенсоры (с подробным объяснением причины и вариантов).
 
 
 
''' 19.05.2006 '''
 
в ядрах vs26-smp-2.6.16-alt3 обнаружена [https://bugzilla.altlinux.org/show_bug.cgi?id=9591 проблема] с утечкой памяти. lakostis@ обещает выложить исправленные пакеты.
 
 
 
''' 18.05.2006 '''
 
mithraen@ [http://lists.altlinux.org/pipermail/devel/2006-May/032754.html сообщает], что <div style="display: inline; color: red;">postgresql</div> 7.x ему более поддерживать неинтересно.
 
 
 
inger@ [http://lists.altlinux.org/pipermail/devel/2006-May/032807.html говорит], что в сизиф собирается <div style="display: inline; color: red;">ncurses/ncursesw-5.5</div>.
 
 
 
rider@ [http://lists.altlinux.org/pipermail/sisyphus/2006-May/081799.html предупреждает] про словленный с <div style="display: inline; color: red;">gnupg</div> '''[https://bugzilla.altlinux.org/show_bug.cgi?id=9587 сегфолт]'''.  Он же [http://lists.altlinux.org/pipermail/sisyphus/2006-May/081809.html рекомендует] обновить <div style="display: inline; color: red;">udev</div> тем, у кого были проблемы с /dev/urandom (нерабочие sshd/ssh в т.ч.).
 
 
 
'''06.05.06'''
 
Есть проблемы с <div style="display: inline; color: red;">hal-0.5.7-alt3</div> и <div style="display: inline; color: red;">ivman-0.6.12-alt1</div>. Пока не стартует hal не будет работать ivman. Название службы у hal не так давно изменилось на haldaemon и у многих он просто пропал из списка установленных и стартующих при загрузке. Кроме того, группу ivman в его файле настроек нужно поменять на xgrp. Указанная там "из коробки" группа отсутствует.
 
 
 
''' 04.05.06 '''
 
Если у кого-либо (как у меня) возникли проблемы с загрузкой с <div style="display: inline; color: red;">udev-091</div>, то поступило [http://lists.altlinux.org/pipermail/sisyphus/2006-May/081244.html известие], что апстрим отловил и вскоре ожидается исправление.
 
 
 
''' 03.05.2006 '''
 
Как и [http://lists.altlinux.org/pipermail/devel-kernel/2006-March/005998.html обсуждалось], теперь в ядрах [http://alt.linux.kiev.ua/srpm/kernel-image-std26-up std26]/[http://alt.linux.kiev.ua/srpm/kernel-image-vs26-smp vs26] используется патч [http://alt.linux.kiev.ua/srpm/kernel-fix-security-altsec altsec]; соответственно <tt>/proc</tt> местами доступен группе <tt>proc</tt>, а <tt>dmesg</tt> -- пользователю <tt>root</tt>.
 
 
 
==== Апрель ====
 
''' 17.04.2006 '''
 
[http://lists.altlinux.org/pipermail/devel/2006-April/031140.html [devel] Спасайся кто может ;): hal, udev, dbus, pmount - обновлены до новых версий]
 
 
 
''' 13.04.2006 '''
 
Тем, кто не хочет видеть интерфейс GNOME на смеси русского и английского языков, не рекомендуется ставить пакет <div style="display: inline; color: red;">libgnome</div>-2.14.1-alt1 -- в нём оказались потеряны файлы переводов. В сборке -alt2 всё будет исправлено.
 
 
 
==== Март ====
 
''' 31.03.2006 '''
 
raorn@ [http://lists.altlinux.org/pipermail/devel/2006-March/030711.html предупредил], что в Sisyphus попадает <div style="display: inline; color: red;">vim7</div> и тем, у кого он был уже установлен из Daedalus, придётся сперва ту сборку удалить (её обновление не предусмотрено).
 
 
 
''' 28.03.2006 '''
 
legion@ [http://lists.altlinux.org/pipermail/devel/2006-March/030579.html анонсировал] изменения в структуре репозитория Sisyphus (остаётся только компонента <tt>classic</tt>; требуется вторая строчка с <tt>noarch</tt> вместо <tt>i586</tt>, поскольку симлинков там уже не будет).  Просьба сизифящимся до конца этой недели поправить <tt>/etc/apt/sources.list</tt>. '''[[http://lists.altlinux.ru/pipermail/devel/2006-March/030753.html сделано]]'''
 
 
 
См. ещё один анонс в [http://freesource.info/wiki//devel/changes изменениях разработчикам].
 
 
 
''' 24.03.2006 '''
 
Понемногу перерабатывается <tt>xorg-x11-xfs</tt> в сторону необязательности; см. [http://lists.altlinux.org/pipermail/devel/2006-March/030391.html этот тред].
 
 
 
''' 16.03.2006 '''
 
[http://lists.altlinux.org/pipermail/sisyphus/2006-March/079349.html Отмечают], что в ядре 2.6.14 модуль <tt>skystar2</tt> убрали как устаревший, а вся поддержка переехала в модуль <tt>b2c2-flexcop-pci</tt>.
 
 
 
''' 09.03.2006 '''
 
Если кто-то не заметил, то опять [http://lists.altlinux.org/pipermail/devel/2006-March/029796.html изменилась подпись репозитория] (с обновлением пакета <div style="display: inline; color: red;">alt-gpgkeys</div> заранее).
 
 
 
'''03.03.2006'''
 
Поведение сервиса <div style="display: inline; color: red;">iptables</div> по умолчанию касательно загрузки счётчиков [http://lists.altlinux.org/pipermail/sisyphus/2006-March/078892.html изменилось].
 
 
 
В версии 2.0.0 изменился формат и место расположения файлов конфигурации плейера <div style="display: inline; color: red;">cmus</div>. Старая конфигурация подхвачена не будет.
 
 
 
'''02.03.2006'''
 
Майнейнер <div style="display: inline; color: red;">asterisk</div> [http://lists.altlinux.ru/pipermail/devel/2006-March/029658.html предупреждает], что обновление на 1.3.0-alt4.10 должно быть весьма тщательно обдуманным -- множество изменений.
 
 
 
==== Февраль ====
 
'''17.02.2006'''
 
Сломалось dhcp из etcnet. Подробности?
 
 
 
''' 16.02.2005 '''
 
Прединфарктное состояние у некоторых вызвало перемещение mod_php5 в orphaned. Не произошло ничего страшного: пакет просто переименован в apache-mod_php5. Счастливые обладатели снапшота от 14.02  кроме apache-mod_php5-5.1.3, все еще имеют mod_php5-5.1.2 (сломанный).
 
 
 
''' 15.02.2005 '''
 
[http://lists.altlinux.ru/pipermail/devel/2006-February/029020.html Предупреждают] о возможных проблемах с <tt>mjpegtools</tt>, <tt>dvgrab</tt> и известных с <tt>xawtv</tt> вследствие обновления <div style="display: inline; color: red;">libquicktime</div> до 0.9.8.  Рекомендуется hold.
 
 
 
''' 11.02.2006 '''
 
[JT] [http://lists.altlinux.ru/pipermail/devel/2006-February/028873.html Отмечается], что Sisyphus достиг [http://lists.altlinux.ru/pipermail/sisyphus-cybertalk/2006-February/000326.html пяти с половиной тысяч] исходных пакетов с [http://lists.altlinux.ru/pipermail/sisyphus-cybertalk/2006-February/000330.html двумя тысячами] открытых багрепортов. :-)
 
 
 
''' 09.02.2006 '''
 
Если после обновления <div style="display: inline; color: red;">libX11</div> перестала работать часть иксового софта, включая WindowMaker -- следует сделать: <tt>echo /usr/X11R6/lib >> /etc/ld.so.conf.d/x11lib; ldconfig</tt>
 
Майнтейнер в курсе, уже отправил новый пакет в сизиф.
 
 
 
''' 08.02.2006 '''
 
zerg@ [http://lists.altlinux.ru/pipermail/devel/2006-February/028830.html пояснил] возможные вопросы касательно <tt>-lacl</tt> при сборке kde-зависимых пакетов => при столкновении надо добавить <tt>BuildRequires: libacl-devel libattr-devel</tt>
 
 
 
Он же [http://lists.altlinux.ru/pipermail/sisyphus/2006-February/077946.html посоветовал] удалить <tt>/etc/xdg/menus/applications-merged/applications.menu</tt>, после чего KDE-3.5.1 в сизифе приходит в себя по части FD-части меню и привязок; и погрозился исправить.
 
 
 
Также если после обновления у вас перестала переключаться раскладка клавиатуры, то вы наверняка пользовались <tt>~/.xkb</tt>. Он сменён на <tt>~/.Xkbmap</tt>. См. подробности на [http://wiki.sisyphus.ru/devel/X http://wiki.sisyphus.ru/devel/X], а также [[altbug:9012]]
 
 
 
 
 
''' 03.02.2006'''
 
В драйвере для видеочипов семейства <div style="display: inline; color: red;">i810</div> версии 1.5.0.0 [http://lists.altlinux.ru/pipermail/sisyphus/2006-February/077692.html обнаружена] неприятная бага (тёмный экран/отлетевшая клавиатура); исправление -- пока откатом на версию [http://lists.altlinux.ru/pipermail/sisyphus/2006-February/077696.html 1.4.1.3].
 
 
 
'''После установки <div style="display: inline; color: red;">apt-conf-sisyphus-2.0-alt1</div> обратите внимание, что появились файлы с репозиториями в sources.list.d, а значит к вашим настройкам без спроса добавятся репозитории в Интернете, причём для hasher также.  [[altbug:5327]]
 
[[altbug:9048]]
 
'''
 
 
 
''' 02.02.2006 '''
 
Дмитрий Левин [http://lists.altlinux.ru/pipermail/devel/2006-February/028660.html предупреждает] сборщиков пакетов, содержащих <tt>*.pc</tt>, об изменениях в <div style="display: inline; color: red;">rpm-build</div> >= 4.0.4-alt58, во избежание атаки unmet'ов.
 
 
 
Костик Лепихов [http://lists.altlinux.ru/pipermail/sisyphus/2006-February/077629.html рассказывает], на что стоит обратить внимание при переезде на отправившийся в Sisyphus <div style="display: inline; color: red;">MySQL5</div>.
 
UPDATE: shrek@ [http://lists.altlinux.org/pipermail/devel/2006-February/028741.html описал] решение ещё одной проблемы с некоторыми пакетами, зависящими от libMySQL.
 
 
 
[http://lists.altlinux.ru/pipermail/sisyphus/2006-February/077655.html Говорят], что <div style="display: inline; color: red;">ipw2200</div> обзавёлся проблемами; пока их чинят, [http://lists.altlinux.ru/pipermail/sisyphus/2006-February/077659.html помогает] <tt>options ipw2200 hwcrypto=0</tt> в /etc/modules.conf.
 
 
 
==== Январь ====
 
''' 28.01.2006 '''
 
Евгений Остапец  сообщает о [https://bugzilla.altlinux.org/show_bug.cgi?id=8986 проблемах] при обновлении <div style="display: inline; color: red;">nss_ldap</div> до версии 244. Чтобы жизнь была легче, стоит задать таймауты в /etc/nss_ldap.conf:
 
<pre>nss_reconnect_sleeptime 2
 
nss_reconnect_maxsleeptime 2
 
nss_reconnect_maxconntries 2
 
nss_reconnect_tries 2</pre>
 
еще имеет смысл
 
<pre>bind_policy soft</pre>
 
''' 27.01.2006 '''
 
Обновление <div style="display: inline; color: red;">libqt3</div> чревато слётом стилей KDE и [http://lists.altlinux.ru/pipermail/sisyphus/2006-January/077413.html некоторыми другими неприятностями] -- следствие исправления ошибки.
 
 
 
''' 22.01.2006 '''
 
Обновление до KDE-3.5 может привести к тому, что в меню появится куча старых/ненужных/лишних ошметков от пунктов меню (openoffice 1.1.x, комерческое ПО, etc). Корень зла может находится в <tt>~/.kde/share/applnk</tt>.
 
 
 
''' 19.01.2006 '''
 
[http://lists.altlinux.ru/pipermail/sisyphus/2006-January/076686.html Предупреждают], что etcnet-0.8.0-alt1 не имеет зависимости на ethtool, но не поднимает без него сеть.
 
<div style="display: inline; color: red;">UPDATE</div>: дело не в ethtool, лучше дождитесь версии 0.8.1.
 
 
 
''' 18.01.2006 '''
 
Перед обновлением glibc старожилы настоятельно [http://lists.altlinux.ru/pipermail/sisyphus/2006-January/076562.html рекомендуют] удалить glibc-core-i686.
 
 
 
''' 16.01.2006 '''
 
Если у вас при обновлении (пакета xinitrc) слетел KDM, как временное решение можно сделать
 
<pre>ln -s /usr/bin/runwm /usr/X11R6/bin/runwm</pre>
 
 
 
=== 2005 ===
 
==== Декабрь ====
 
''' 30.12.2005 '''
 
Тем, кто пользуется KMail, следует поостеречься с обновлением до KDE 3.5: как-то слишком тормозить стал, вылетает. А также могут быть проблемы из-за смены схемы работы с IMAP.
 
 
 
однако gns говорит: у меня все хорошо работает. единственное, вернулся старый глюк - когда на imap включено отображение тредов, очень редко исчезает текст из списка сообщений, остаются пустые строки в виде дерева. переключение по папкам восстанавливает нормальный вид. крэшей за три дня пользования не было.
 
 
 
''' 26.12.2005 '''
 
Майнтейнер <div style="display: inline; color: red;">rp-pppoe</div> [http://lists.altlinux.ru/pipermail/sisyphus/2005-December/075308.html рекомендует] пока поставить пакет на hold.
 
 
 
Майнтейнер <div style="display: inline; color: red;">libao</div> [http://lists.altlinux.ru/pipermail/sisyphus/2005-December/075314.html говорит]: "если у вас после этого обновления пропадёт звук, надо просто сказать: <tt>apt-get install libao-full</tt>" ([https://bugzilla.altlinux.org/show_bug.cgi?id=8633 #8633])
 
 
 
''' 25.12.2005 '''
 
Если у вас используются pcmcia-карты, после обновления они перестанут работать из-за того, что в /etc/modules.conf  осталось
 
<pre>pre-install pcmcia_core CARDMGR_OPTS=-f /etc/rc.d/init.d/pcmcia start</pre>
 
См. [[altbug:8733]]
 
 
 
 
 
'''дополнение:''' могут и не дождаться _после_, а перестать работать непосредственно во время обновления, что особенно чревато при забирании пакетов по NFS через сетевую карту в PCMCIA-слоте.  Предполагаемый быстрый объезд -- <tt>chmod -x /etc/init.d/pcmcia</tt> _перед_ обновлением, чтоб не смог выдернуть <tt>yenta_socket</tt> или на чём слот живёт. ''([http://lists.altlinux.ru/pipermail/sisyphus/2005-December/075588.html mike@])''
 
 
 
'''17.12.2005'''
 
В пакете <div style="display: inline; color: red;">fvwm</div> <div style="display: inline; color: red;">2.5.14-alt1</div>, который скоро будет в Сизифе, все файлы переехали из <tt>/usr/X11R6</tt> в <tt>/usr</tt>, поэтому нужно быть внимательным при обновлении, возможно, придётся поправить какие-то пути в своей конфигурации.  Пакет  <div style="display: inline; color: red;">fvwm-themes</div> <div style="display: inline; color: red;">0.7.0-alt1</div> несовместим с новой сборкой fvwm; <s>пользователям fvwm-themes рекомендуется поставить fvwm на Hold до выхода обновления fvwm-themes ([[altbug:8673]]
 
)</s>.
 
 
 
'''11.12.2005'''
 
Андрей Булава [http://lists.altlinux.ru/pipermail/sisyphus/2005-December/074635.html сообщает] о известных проблемах с vmware-5.0 и linux-2.6.14.  Выход -- 5.5, 2.6.12 или патчить.
 
 
 
'''06.12.2005'''
 
Прозвучала отмена грядущего шторма от 05.12.2005. В сизиф выложен <div style="display: inline; color: red;">Xorg</div>-6.9 а не 7.0. Владельцы nvidia <tt>пока</tt> могут спать спокойно ;)
 
 
 
 
 
'''05.12.2005'''
 
<s>Прозвучало предупреждение владельцам карт NVIDIA -- в Sisyphus уходит <div style="display: inline; color: red;">Xorg</div>-6.99.99.903 aka 7.0, под который ещё не собран пакет с драйвером nvidia (...а также переехавший из /usr/X11R6 в /usr).</s>
 
 
 
==== Ноябрь ====
 
'''28.11.2005'''
 
В связи с приездом в сизиф nss, [http://lists.altlinux.org/pipermail/sisyphus/2005-November/073900.html сообщают] о том, что снова запускаются гномовские часики. Чтобы они запустились и у вас, на машине должны стоять два пакета, не вытягивающиеся по зависимостям: libnss и libnspr.
 
 
 
Майнтейнер <div style="display: inline; color: red;">xorg-x11</div> [http://lists.altlinux.ru/pipermail/sisyphus/2005-November/073973.html понял] одну из проблем, возникших у некоторых в связи с отказом от использования xfs по умолчанию.  Изначально замечание было про "русские буковки в меню xmms"...
 
 
 
'''27.11.2005'''
 
Майнтейнер <div style="display: inline; color: red;">xorg-x11</div> [http://lists.altlinux.ru/pipermail/devel/2005-November/026865.html предупреждает] о приближающемся... нет, всего лишь X.Org-7.0.  Переезд (с прицелом на [http://lists.altlinux.ru/pipermail/devel/2005-November/026568.html исчезновение] <tt>/usr/X11R6</tt>) предполагается по возможности автоматический; майнтейнерам пакетов со шрифтами стоит уделить внимание на драфт FreeSource:AltLinux/Policy/Fonts.
 
 
 
'''25.11.2005'''
 
Завтра [http://lists.altlinux.ru/pipermail/sisyphus/2005-November/073778.html ожидается] исправление новой сборки <div style="display: inline; color: red;">php</div>, обладающей кроме ряда полезных [http://lists.altlinux.ru/pipermail/sisyphus/2005-November/073721.html фич] и [http://lists.altlinux.ru/pipermail/sisyphus/2005-November/073778.html проблемами] при обновлении.  Бишь 4.4.2-alt0.cvs20051121 лучше не ставить, подождав alt0.cvs20051121.1.
 
 
 
'''24.11.2005'''
 
Майнтейнер emacs22 в Daedalus [http://lists.altlinux.ru/pipermail/devel/2005-November/026728.html интересуется] мнением общественности по поводу emacsen в Sisyphus, предлагая своё видение вариантов.
 
 
 
Предлагается поставить <div style="display: inline; color: red;">fuse</div> на Hold или предпринять [http://lists.altlinux.ru/pipermail/devel/2005-November/026738.html иные действия] для поддержания работоспособности до синхронизации kernel/userspace.
 
 
 
'''23.11.2005'''
 
Новый <div style="display: inline; color: red;">udev_0.75</div> требует для нормальной работы ядро не ниже <div style="display: inline; color: red;">2.6.12</div>
 
Иначе не все нужные файлы создаются в /dev
 
 
 
'''19.11.2005'''
 
Мейнтейнер GNOME [http://lists.altlinux.org/pipermail/sisyphus/2005-November/073526.html категорически не рекомендует] обновлять <div style="display: inline; color: red;">Mozilla</div> до версии 1.7.12-alt3, поскольку в этой версии мейнтейнер Mozilla перенес библиотеки из /usr/lib в /usr/lib/mozilla, что приводит к массовому отказу программ (в том числе апплета часов GNOME), зависящих от них и собранных в расчёте на то, что библиотеки лежат по старому пути. Сломалась также сборка пакетов, зависящих от Mozilla.
 
 
 
'''15.11.2005'''
 
В связи с обнаруженными проблемы безопасности в sudo рекомендуется добавить в /etc/sudoers строку <pre>Defaults    env_reset</pre> и исправить всё, что перестанет работать :)
 
 
 
''' 13.11.2005'''
 
<div style="display: inline; color: red;">Проблема с mod_php/php-libs</div>: После обновления до php-libs-4.4.1-alt0.cvs20051010.i586.rpm наблюдается зависание процессов libhttpd пр формировании страниц WackoWiki. Откат решил проблему. [[altbug:8486]]
 
 
 
Будьте осторожны с обновлением dhcp-server - [[altbug:8493]]
 
 
 
 
 
''' 12.11.2005 '''
 
Если вам нужна Java для [[changes/OpenOffice.org2|OpenOffice.org2]], ставьте пакет j2se1.4-blackdown - это та версия, с которой ООо собирался.
 
 
 
''' 10.11.2005 '''
 
Обновление libgsf (для gnumeric) чревато переменами для libwv libwv2 libwpd abiword koffice-kword librsvg2.
 
 
 
''' 07.11.2005'''
 
Мейнтейнер <div style="display: inline; color: red;">Meld</div> рекомендует воздержаться от обновления до версии 1.1.1, в связи с [https://bugzilla.altlinux.org/show_bug.cgi?id=8428 проблемами в русификации]. Или, если уж вы обновились, помогите с поиском причины бага.
 
 
 
Обратите внимание, что пока gnumeric "не живой", так что воздержитесь от обновления libgal2.
 
 
 
''' 05.11.2005 '''
 
"Если проявятся дубликаты пунктов меню -- не пугайтесь, в будущем это будет исправлено в лучшую сторону", [http://lists.altlinux.ru/pipermail/sisyphus/2005-November/072783.html предупреждает] майнтейнер <div style="display: inline; color: red;">menu</div>.
 
 
 
==== Октябрь ====
 
''' 13.10.2005 '''
 
С <s>новыми</s> <div style="display: inline; color: red;">drm</div>-модулями, собранными с <div style="display: inline; color: red;">kernel-source-drm</div> версии <div style="display: inline; color: red;">2005.10.08</div>, не работает DRI при использовании модуля i915 ( например для таких видеокарт, как i855GM) - <s>[[altbug:8205]]
 
</s>.  '''UPD:''' в модулях <div style="display: inline; color: red;">drm</div> версии <div style="display: inline; color: red;">2005.11.18</div> эта проблема исправлена.
 
 
 
На сообщение о проблеме с <div style="display: inline; color: red;">hal</div> (не монтируется USB HDD) последовало "[http://lists.altlinux.ru/pipermail/sisyphus/2005-October/071369.html hal-0.5.4-alt5 исправляет]".
 
 
 
''' 07.10.2005 '''
 
Тихо и сперва незаметно обновился <div style="display: inline; color: red;">rpm</div> до версии <div style="display: inline; color: red;">4.0.4-alt49</div>, исправляя [https://bugzilla.altlinux.org/show_bug.cgi?id=8089 #8089], что вызвало широкий [http://lists.altlinux.ru/pipermail/devel/2005-October/025111.html резонанс] среди разработчиков. '''UPD:''' [http://lists.altlinux.ru/pipermail/devel/2005-October/025229.html смягчение проблемы]
 
 
 
==== Сентябрь ====
 
''' 27.09.2005 '''
 
Дмитрий Левин [http://lists.altlinux.ru/pipermail/sisyphus/2005-September/070518.html предупреждает] об обновлении <div style="display: inline; color: red;">Linux-PAM</div> и необходимости перезапустить после оного сервисы, его использующие (включая sshd и crond, а также *dm).
 
 
 
''' 18.09.2005 '''
 
Если наблюдаются кракозябры вместо кириллицы в менюшках, например, xmms -- проверьте, установлен ли пакет [http://lists.altlinux.ru/pipermail/sisyphus/2005-September/069701.html xorg-x11-cyrillic-fonts] ''[умеренно старые грабли]''
 
[https://bugzilla.altlinux.org/show_bug.cgi?id=7999 xorg-x11-server-6.8.99.900-alt6]: <div style="display: inline; color: red;">[http://lists.altlinux.ru/pipermail/sisyphus/2005-September/069711.html Перестали работать Иксы]</div> для Radeon 7000, 9800 (похоже любых). Работает VESA и fbdev. Кстати, зато в этих режимах пиктограммы нормально рисуются [https://bugzilla.altlinux.org/show_bug.cgi?id=7831 #7831]. Правда в VESA в KDE пиктограммы уплывают со своих мест...
 
 
 
''' 13.09.2005 '''
 
после обновления на <div style="display: inline; color: red;">dbus-0.50</div> он перестает работать... необходимо очистить содержимое каталога /var/run/dbus/ и выполнить service messagebus restart
 
 
 
''' 08.09.2005 '''
 
<div style="display: inline; color: red;">wget-1.10.1</div> имеет проблемы с SSL, отсутствовавшие в 1.10.  Майнтейнер в курсе, апстрим -- не знаю.
 
 
 
''' 05.09.2005 '''
 
Новый ведущий майнтейнер <div style="display: inline; color: red;">GNOME</div> сообщает об уже обнаруженных в 2.12 [https://lists.altlinux.ru/pipermail/sisyphus/2005-September/068647.html граблях], в особенности касательно gnome-panel.
 
 
 
<s>Новый и улучшенный <div style="display: inline; color: red;">xorg-x11-6.8.99.900-alt5</div>: теперь [https://lists.altlinux.ru/pipermail/sisyphus/2005-September/068671.html ломает] даже [https://bugzilla.altlinux.org/show_bug.cgi?id=7849 acpid]. :-)</s>  Обновляемся до acpid-1.0.4-alt5.
 
 
 
Если в k3b куда-то пропало нижнее окошко с кнопками создания проектов, попробуйте [http://lists.altlinux.ru/pipermail/sisyphus/2005-October/071070.html стереть настройки]. ''(задним числом)''
 
 
 
''' 04.09.2005 '''
 
"[http://lists.altlinux.ru/pipermail/sisyphus/2005-September/068578.html Данное письмо] адресуется всем сделавшим dist-upgrade и получившим в итоге нерабочий kcontrol, ненастраиваемый konqueror и может ещё чего..."
 
 
 
''' 03.09.2005 '''
 
Только для старожилов: начиная с pam-0.80-alt0.1 (выпущенного 18.07.2005) можно [https://bugzilla.altlinux.org/show_bug.cgi?id=7847 столкнуться] с проблемой отсутствия pam_stack.so при его использовании в /etc/pam.d. Например, может оказаться недоступной команда su.
 
 
 
'''02.09.2005'''
 
Существенно обновился libgtk+2 и его зависимости. В связи с этим возможны проблемы с программами, использующими Perl-Gtk, wxGTK (import wxPython с необновлённым wxGTK приводит к [https://bugzilla.altlinux.org/show_bug.cgi?id=7791 аварийному завершению] - исправлено 2005-09-15 в wxGTK2u-2.6.1-alt1.1), PyGtk.
 
 
 
 
 
==== Август ====
 
'''31.08.2005'''
 
Из Иксов [http://lists.altlinux.ru/pipermail/sisyphus/2005-August/068356.html убрана] раскладка <tt>ctrl_toggle</tt> - пользуйтесь <tt>rctrl_toggle</tt> или <tt>lctrl_toggle</tt>, а лучше  <tt>caps_toggle</tt> :)
 
'''25.08.2005'''
 
После обновления pam* и tcb* пакетов может не пускать по ssh, выдавая в консоль "Connection to ssh-host closed by remote host.", а в логах машины, куда заходим -- "sshd[26967]: fatal: PAM session setup failed[6]: Permission denied". Решение проблемы -- комментирование строчки с pam_limits в /etc/pam.d/system-auth.
 
 
 
'''24.08.2005'''
 
Ограничились права на запуск X, возможно потребуется изменить их с помощью <tt>control xorg-server</tt>
 
Причём сообщение о проблеме при запуске startx может выглядеть так:
 
<div style="display: inline; background-color: red;">PAM autentication failed, cannot start X server.</div>
 
<div style="display: inline; background-color: red;">Perhaps you do not have console ownership</div>?
 
См. также [https://bugzilla.altlinux.ru/show_bug.cgi?id=7752 https://bugzilla.altlinux.ru/show_bug.cgi?id=7752]
 
 
 
''' 17.08.2005 '''
 
<s>В версии 1.13 шрифтов DejaVu некорректно отображается шрифт DejaVu Sans Mono. Апстрим извещён, а пока, если вы пользуетесь моноширинным шрифтом из DejaVu, лучше остаться на 1.12.</s>
 
Update: отбой тревоги, проблемы исправлены в 1.13-alt2.
 
 
 
''' 16.08.2005 '''
 
etcnet-0.7.11-alt1 сломан -- нет файла /etc/net/options.d/00-default. в -alt2 пофиксено.
 
 
 
В пакете <div style="display: inline; color: red;">firefox-1.0.6</div> обнаружена критическая ошибка. Пожалуйста, воздержитесь от установки версии firefox-1.0.6-alt3. ([http://lists.altlinux.ru/pipermail/sisyphus/2005-August/067410.html ссылка])
 
В Сизифе появился исправленный пакет '''firefox-1.0.6-<div style="display: inline; color: red;">alt4</div>'''
 
 
 
''' 11.08.2005 '''
 
Обновление X.Org до [http://lists.altlinux.ru/pipermail/devel/2005-August/023035.html 6.9RC] приводит к несовместимости текущей версии драйверов ATI (fglrx).  Их обновление ожидается в конце месяца, до тех пор следует либо поставить xorg-x11 на Hold, либо принять участие в тестировании [http://lists.altlinux.ru/pipermail/devel/2005-August/023039.html обновлённого драйвера ati] (должен поддерживать до r300).
 
 
 
'''08.08.2005'''
 
После обновления X.Org, касающегося пользовательских файлов xkb, невозможно залогиниться из dm, при этом в .xsession-errors никаких явных неприятностей нет. Проблема связана с файлом /etc/X11/xinit.d/xkb, замена его на [http://lists.altlinux.ru/pipermail/sisyphus/2005-August/066256.html предлагаемый] исправляет ситуацию.
 
 
 
'''03.08.2005'''
 
Если кто-либо пропустил [http://lists.altlinux.ru/pipermail/devel-kernel/2005-June/005644.html обсуждение], то вот [http://lists.altlinux.ru/pipermail/sisyphus/2005-August/065522.html предупреждение] по поводу опасности связки <tt>-t vfat -o sync</tt> и Linux 2.6.12 для здоровья USB Flash.
 
 
 
Также, тем кто собирает пакеты на хост-системе не последней свежести необходимо обновить сам пакет apt (см сообщение от 21.07.2005), иначе с сегодняшнего дня такая сборка станет невозможна.
 
 
 
==== Июль ====
 
 
 
'''21.07.2005'''
 
Анонс новой сборки пакета <div style="display: inline; color: red;">apt-conf</div> содержит рекомендацию обновить его (возможно, вручную), поскольку добавлен ещё один ключ и в ближайшее время он также начнёт использоваться. ([http://lists.altlinux.ru/pipermail/sisyphus/2005-July/064782.html ссылка]; [http://lists.altlinux.ru/pipermail/sisyphus/2005-July/064781.html накладка]; [http://lists.altlinux.ru/pipermail/sisyphus/2005-July/064797.html "вручную"];
 
[http://lists.altlinux.ru/pipermail/sisyphus/2005-July/064911.html новый apt-conf со старой подписью])
 
 
 
'''20.07.2005'''
 
''(Немного запоздало)'' После обновления <div style="display: inline; color: red;">alsa-oss</div> до 1.0.9 может падать <div style="display: inline; color: red;">xmms</div>. Если совет от 12.07.2005 не помог,  попробуйте запускать xmms как <tt>/usr/bin/xmms-bin</tt> (или как <tt>/usr/bin/xmms</tt> если <tt>xmms-bin</tt> отсутствует). Можно также установить <tt>xmms-out-alsa</tt> и настроить в xmms вывод через ALSA. См. также [https://bugzilla.altlinux.org/show_bug.cgi?id=7303 здесь]
 
 
 
''' 13.07.2005 '''
 
Антон Фарыгин, он же Rider, заблаговременно [http://lists.altlinux.ru/pipermail/sisyphus/2005-July/064135.html предупреждает] всех о грядущих переменах, связанных с выкатыванием новіх версий udev, hal, dbus... Общий диагноз:  "теперь точно спасайся кто может", впрочем, есть и утешение: "на моих тестовых машинах все это безобразие работает отлично" ;-)
 
 
 
''' 12.07.2005 '''
 
''(запоздало, но народ уже начинает спотыкаться)'' ldv@ [http://lists.altlinux.ru/pipermail/devel/2005-July/022140.html предупреждает] об изменении поведения <div style="display: inline; color: red;">make</div> (улучшает совместимость с POSIX, но ухудшает обратную)
 
 
 
[http://lists.altlinux.ru/pipermail/sisyphus/2005-July/063984.html Замечено], что юзерспейсная <div style="display: inline; color: red;">alsa-1.0.9</div> (в частности aoss) не вполне дружит с kernel-modules-alsa версии 1.0.8; при странных сегфолтах следует в первую очередь обновить модули.
 
 
 
''' 07.07.2005 '''
 
Антон Фарыгин, он же Rider, заблаговременно [http://lists.altlinux.ru/pipermail/sisyphus/2005-July/063606.html предупреждает] всех о грядущих переменах, связанных с выкатыванием udev-0.6.0. Общий диагноз:  "спасайся кто может"
 
 
 
''' 06.07.2005 '''
 
Вчера отмечались проблемы с запуском <div style="display: inline; color: red;">firefox</div> после обновления -- лечатся удалением пакетов и установкой с нуля, возможно, связано с правками по обновлению плагинов, жду уточнения.  Следует также проверить наличие процессов <tt>firefox-bin</tt>, если не сегфолт, а задумчивость. [[altbug:6111]]
 
 
 
 
 
<div style="display: inline; color: red;">nvidia</div> может потребовать пинка в виде запуска <tt>x11setupdrv</tt> для выравнивания симлинков. [http://lists.altlinux.ru//pipermail/sisyphus/2005-July/063533.html подробности]
 
'''update:''' помимо пинка, может потребоваться замена <tt>Load &quot;/usr/X11R6/lib/modules/extensions/libglx.so~&quot;</tt> на <tt>Load &quot;glx~&quot;</tt> в <tt>/etc/X11/xorg.conf</tt>
 
 
 
''' 02.07.2005 '''
 
<div style="display: inline; color: red;">postfix-2.2.4-alt3</div> содержит Sisyphus:admin/postfix-2.2.4-alt3, способных повлиять на работу скриптов, которые используют newaliases(1), postalias(1) или postmap(1).
 
 
 
 
 
==== Июнь ====
 
 
 
''' 24.06.2005 '''
 
Пакет <div style="display: inline; color: red;">squid</div> меняет структуру, незаинтересованным майнтейнер [http://lists.altlinux.ru/pipermail/sisyphus/2005-June/062730.html предлагает] пока на Hold.
 
Он же сообщает о том, что <div style="display: inline; color: red;">etcnet-0.7.6</div> может быть нестабильной и [http://lists.altlinux.ru/pipermail/sisyphus/2005-June/062735.html рекомендует] нежелающим рисковать подождать 0.7.7.
 
 
 
'''17.06.2005'''
 
<div style="display: inline; color: red;">hasher-1.0.17-alt1</div> содержит проблему, исправление -- в 1.0.18-alt1 (на ftp), потребуется удалить <tt>$workdir/cache</tt>. ([http://lists.altlinux.ru/pipermail/devel/2005-June/021812.html ссылка])
 
 
 
'''14.06.2005'''
 
стоить <div style="display: inline; color: red;">удалить xresprobe перед dist-upgrade</div>. поскольку он конфликтует с ddcprobe=>hardware, из-за этого не обновляется  nvidia_glx_common и apt начинает выносить все зависящее от xorg-x11-mesagl. ирония в том что в итоге он все равно удаляет xresprobe , но hardware не ставит.
 
 
 
'''10.06.2005'''
 
<div style="display: inline; color: red;">xorg-x11-6.8.2-alt8</div> включает обновлённый драйвер i810, в котором сломано определение частот (см. лог про 100000Mhz).  Исправление (откат) будет в alt9.
 
 
 
Несмотря на то, что осиротевший (->orphaned) было libhowl стараниями добротелей вернулся в Сизиф, для GNOME, который от него зависит, он бесполезен из-за несовпадения soname. Ждём либо пересборки GNOME с новым libhowl, либо пересборки &laquo;старого&raquo; libhowl.
 
 
 
'''09.06.2005'''
 
<s>Уточнение: новый механизм переключения libGL подразумевает запуск <tt>setgl</tt> из пакета <tt>hardware</tt>. ([http://lists.altlinux.ru/pipermail/sisyphus/2005-June/061703.html ссылка])</s>
 
Уточнение2: (vsu) иногда требуется ещё <tt>apt-get reinstall xorg-x11-mesagl</tt>
 
[http://lists.altlinux.ru/pipermail/sisyphus/2005-June/062766.html Начиная с 15.06.2005] для включения libGL нужно запустить <tt>x11setupdrv</tt> из одноимённого пакета.
 
 
 
'''07.06.2005'''
 
При обновлении до <div style="display: inline; color: red;">xorg-x11-6.8.2-alt8</div> будут снесены старые версии драйверов nvidia и fglrx (nvidia_glx_common <= 1.0.7174-alt4, fglrx_glx <= 8.12.10-alt1) из-за изменившегося механизма переключения libGL.so.1. Если эти драйверы необходимы, подождите их новых сборок.
 
 
 
'''02.06.2005'''
 
Перезапуск WindowMaker'а 0.91 при изменения окна с зажатым alt'ом. Точное описание проблемы и её решение [http://lists.altlinux.ru/pipermail/sisyphus/2005-June/061255.html тут].
 
 
 
'''02.06.2005'''
 
имеющийся php-mmcache с mod_php-4.3.12-alt0.cvs20050530 может приводить к падению apache child processes ([https://bugzilla.altlinux.org/show_bug.cgi?id=6990 #6990])
 
 
 
 
 
==== Май ====
 
'''29.05.2005'''
 
<div style="display: inline; color: red;">php-4.3.12-alt0.cvs20050527</div>, кажется, сломан (Sisyphus:admin/php-4.3.12-alt0.cvs20050527)
 
 
 
'''28.05.2005'''
 
<div style="display: inline; color: red;">Achtung</div> Обновление от 28 мая выявило следующее: после dist-upgrade  ломается sshd и никого не пускает.
 
Решение: не покидая консоль, где выполнялся dist-upgrade, выполнить service sshd restart.
 
 
 
'''26.05.2005'''
 
<div style="display: inline; color: red;">startup-0.9.8-alt1</div> теперь поддерживает mdadm (софтовый RAID): это заключается в том, что если у вас не был правильно настроен (но присутствовал) mdadm.conf, то система перестанет штатно загружаться после обновления. Sisyphus:admin/startup-0.9.8-alt1
 
 
 
<div style="display: inline; color: red;">pam-config-1.2.0-alt1</div> содержит некоторые изменения, о которых ldv@ Sisyphus:admin/pam-config-1.2.0-alt1.
 
 
 
<div style="display: inline; color: red;">PostgreSQL 8.0.3</div> замечен в падениях на INSERT (8.0.2 -- вроде нет).  Sisyphus:admin/PgInsertCore
 
 
 
<div style="display: inline; color: red;">SquidGuard 1.2.0-alt5</div> неадекватно себя ведёт из-за опечатки в блэклисте (Sisyphus:admin/SquidGuard).
 
 
 
'''24.05.2005'''
 
Новый <div style="display: inline; color: red;">mc</div>, к которому приложен юникодный патч, разучился перекодировать в редакторе/вьювере. ([https://bugzilla.altlinux.org/show_bug.cgi?id=6944 #6944])
 
Также если хотите видеть русские названия файлов под root, укажите в root/.i18n LC_CTYPE равным значению вашей локали.
 
 
 
'''22.05.2005'''
 
<div style="display: inline; color: red;">WindowMaker-0.91</div> -- бэкапим ~/GNUstep, по желанию холдим любимый 0.80.2. Sisyphus:admin/WindowMaker091
 
 
 
'''20.05.2005'''
 
В связи с обновлением kernel-source-ltmodem (и недостаточной оттестированностью этой версии) у пользователей этих драйверов на ядрах 2.6.x могут возникнуть проблемы после обновления.
 
 
 
'''13.05.2005'''
 
Не следует устанавливать ядра 2.6.11-std26-up-alt7/8 -- имеется Sisyphus:admin/2611alt7.
 
 
 
'''11.05.2005'''
 
Обновление glibc (2.3.5-alt1);  Sisyphus:admin/GlibcUpgrade.
 
 
 
'''04.05.2005'''
 
<div style="display: inline; color: red;">GIMP</div> может перестать работать с (некоторыми?) JPEG-файлами; [[changes/GimpJpg|сообщения]] ''(проблема в libexif)''.
 
 
 
'''01.05.2005'''
 
<div style="display: inline; color: red;">Внимание, грабли</div>! Может отвалиться звук, подробности Sisyphus:admin/Sound/ModuleLoadProblem.
 
 
 
==== Апрель ====
 
'''30.04.2005'''
 
Для того, чтобы GNOME ловил на лету (без перевхода) изменения в файловой системе, у вас должен быть запущен FAM. На данный момент для нормальной работы нужно вручную:
 
# Убедиться, что установлен пакет portmap и сервис portmap запускается как минимум в runlevel 5.
 
# Убедиться, что установлен пакет fam (не путать с libfam, на который есть зависимость в gnome-vfs2) и сервис xinetd, через который работает fam, запускается как минимум в runlevel 5.
 
# В файле /etc/xinetd.d/sgi_fam изменить установку disable на no.
 
# (Пере)запустить portmap.
 
## Если вы пытались играться с fam помимо xinetd, тут стоит проверить, что в rpcinfo -p не значится sgi_fam. Если значится, удалить его оттуда командой &laquo;rpcinfo -d sgi_fam 2&raquo;.
 
# Перезапустить xinetd и GNOME.
 
 
 
'''11.04.2005'''
 
Теперь файл sysctl.conf раздвоился: часть, отвечающая за сетевые настройки, теперь находится в /etc/sysconfig/network-scripts/sysctl.conf (если вы не устанавливали etcnet), или в /etc/net/sysctl.conf для etcnet. <div style="display: inline; color: red;">Обратите внимание, что настройки не перенесены - в частности, перестанет работать forwarding</div>
 
 
 
'''06.04.2005'''
 
<div style="display: inline; color: red;">Обновился mod_php</div> Теперь он стал строг к владельцам файлов php и путям ко включаемых файлам. Проверьте свои сайты!
 
Выложено новое KDE (3.4.0). Возможно у некоторых пользователей не будет работать меню в KDE. Зачем-то kdmrc (конфиг kdm) начинает заново, выкидывая старый.
 
 
 
'''05.04.2005'''
 
<s><div style="display: inline; color: red;">Ошибка в пакете startup-0.9.6-alt1.noarch.rpm: системы с reiserfs возможно вообще не загрузятся</div> Рекомендуется параметр -y в вызове fsck заменить на -p (файл /etc/rc.d/rc.sysinit) <div style="display: inline; color: red;">Исправлено в [http://sisyphus.ru/srpm/startup/changelog 0.9.6.1]</div></s>
 
Рекомендуется установить пакет udev_static-complete, чтобы появились "пропавшие" устройства типа /dev/ppp
 
 
 
==== Ранее ====
 
''' 17.02.2005 '''
 
: 1.  При использовании фирменных драйверов (fglrx) не работает нормально tv (v4l) – чёрный экран (xawtv) или зависание. Возможно это связано с DGA, так как DGA не работает и в WINE.
 
: 2. При обновлении [[changes/OpenOffice|OpenOffice]] нужно сделать ссылки [[changes/OpenOffice.org|OpenOffice.org]]-1.1.2, 1.1.3 на [[changes/OpenOffice.org|OpenOffice.org]] в каталоге /usr/lib, иначе будут проблемы при открытии/сохранении документов.
 
 
 
: 4. После обновления возможно перестанет открываться домашний каталог и konqueror с панели. Если не запускается firefox, удалите все его плагины. Чтобы меню было на русском языке, установите firefox-ru и выберите язык в меню Tools->Language. Рекомендуется перейти на submount (одноимённый пакет) (также установив пакет kernel-modules-subfs-std26-up), пример строчек для fstab:
 
<pre>/dev/floppy /mnt/floppy subfs fs=vfat,users,iocharset=koi8-r,sync,quiet,codepage=866,showexec,noexec,umask=0 0 0
 
/dev/cdrom  /mnt/cdrom  subfs      fs=cdfss,iocharset=koi8-r,noexec,nodev,ro,unhide 0 0</pre>
 
 
 
''' 18.01.2005 '''
 
: 1. После обновления Иксов удостоверьтесь, что пакеты xorg-x11-{xfs,xdm ,xserver} установлены в системе, иначе Иксы не запустятся.
 
 
 
''' 17.10.2004 '''
 
#  При обновлении wxGTK-common будет ошибка, поэтому лучше предварительно стереть содержимое каталога /usr/share/wx/2.4 2.
 
После обновления нужно либо перезагрузить систему, либо выполнить
 
<pre># chown root:root /tmp/.ICE-unix</pre>
 
иначе KDE не запустится.
 
:::
 
# Обратите внимание, что конфигурационный файл иксов теперь называется  /etc/X11/xorg.conf
 
# Если возникли проблемы со шрифтами в текстовой консоли, возможно у вас утерялись пакеты console-data и console-tools
 

Версия 10:31, 12 февраля 2019