RaspberryPi firmware

Материал из ALT Linux Wiki
Перейти к навигации Перейти к поиску

При установке на RPi400 образа Альт для RPi4 наблюдается проблема - не работает WiFi и bluetooth.

Причина проблемы - отсутствие в образе нужных для RPi400 файлов firmware.

На RPi3 также требуется дополнительный файл firmware для bluetooth.

Поместить нужные файлы firmware непосредственно в образ нельзя, поскольку их лицензионный статус непонятен.

Для обхода проблемы создан пакет brcm-firmware-setup, содержащий одноимённый скрипт, который загрузит файлы firmware brcm с определённых URL-адресов и скопирует их в папку /lib/firmware/brcm.

Для работы скрипта должно быть подключение к сети интернет. Поскольку WiFi без firmware не работает, подключение нужно организовать по ethernet.